Bug 437963 - configuration not saved atomically
configuration not saved atomically
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gqview (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
https://sourceforge.net/tracker/?func...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 09:25 EDT by Roberto Jimeno
Modified: 2008-03-18 12:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 12:02:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roberto Jimeno 2008-03-18 09:25:15 EDT
Description of problem:
configuration is not saved atomically. So on errors
like out of space a 0 sized file overwrites a good
configuration.

Instead gqview should write configuration to a temp
file and when everything went OK replace the new
configuration file with the old one.

Version-Release number of selected component (if applicable): 2.0.4


How reproducible:
Steps to Reproduce:
1. change a setting in gqview
2. fill disk space
3. quit gqview
4. your gqview config is gone
  
Actual results:
config is gone on full disk

Expected results:
config should be kept on full disk

Additional info:
Severity is high because config is lost
Comment 1 Michael Schwendt 2008-03-18 12:02:58 EDT
Thank you for reporting this, but it's in the upstream tracker
already.

> Date Submitted: 2005-10-03 01:56

I'm not going to fork GQview for a very rare out-of-disk-space
scenario like this when there hasn't been any upstream activity
for more than a year. The implementation is broken by design in
that hardly any fwrite/fprintf return value elsewhere is checked
either. See "grep fprintf * -R|less" for example.

Note You need to log in before you can comment on or make changes to this bug.