Bug 437988 - SELinux prevents printing
SELinux prevents printing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy-targeted (Show other bugs)
5.2
i386 Linux
medium Severity high
: rc
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 11:43 EDT by Matthew Booth
Modified: 2008-03-28 09:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: U2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 09:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
AVCs from audit log when attempting to print (2.24 KB, text/plain)
2008-03-18 11:43 EDT, Matthew Booth
no flags Details

  None (edit)
Description Matthew Booth 2008-03-18 11:43:38 EDT
Description of problem:
Since upgrading to RHEL 5.2 Beta I am unable to print using hplip with SELinux
enabled. If I put SELinux in permissive mode, I get the attached in the audit
log when printing. In case it's relevant, I was attempting to print from
thunderbird.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.6-121.el5.noarch
cups-1.2.4-11.15.el5.i386
hplip-1.6.7-4.1.el5_0.3.i386
thunderbird-2.0.0.12-1.el5.i386
Comment 1 Matthew Booth 2008-03-18 11:43:38 EDT
Created attachment 298408 [details]
AVCs from audit log when attempting to print
Comment 2 Daniel Walsh 2008-03-18 12:08:06 EDT
Looks like this should work in selinux-policy-2.4.6-125.el5.noarch.rpm

Which is the current RHEL5 policy.
Comment 3 Matthew Booth 2008-03-18 12:23:30 EDT
Where can I get that to test?
Comment 4 Daniel Walsh 2008-03-18 14:14:18 EDT
I always make the packages available on 
http://people.redhat.com/dwalsh/SELinux/RHEL5
Comment 5 Matthew Booth 2008-03-26 17:42:34 EDT
I can confirm this is fixed.

Note You need to log in before you can comment on or make changes to this bug.