Bug 437996 - wpa_supplicant fails to start as daemon in rawhide
wpa_supplicant fails to start as daemon in rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 12:18 EDT by Mike C
Modified: 2008-03-18 16:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:47:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
wpa_supplicant (374 bytes, text/plain)
2008-03-18 12:25 EDT, Mike C
no flags Details

  None (edit)
Description Mike C 2008-03-18 12:18:19 EDT
Description of problem: Attempting to start wpa_supplicant as daemon fails


Version-Release number of selected component (if
applicable):wpa_supplicant-0.6.3-5.fc9.i386


How reproducible:Every time


Steps to Reproduce:
1. Test that wpa supplicant starts manually using 
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
2. Now stop the supplicant and attempt to start the daemon
3. service wpa_supplicant (re)start
  
Actual results:
Terminal output is
Starting wpa_supplicant: /etc/wpa_supplicant/wpa_supplicant.conf, -iwlan0,
-Dwextwpa_supplicant: option requires an argument -- f

Expected results:Supplicant daemon should start normally


Additional info:/etc/sysconfig/wpa_supplicant is defined in the normal way
and includes -f as an argument to OTHER_ARGS
Comment 1 Mike C 2008-03-18 12:25:05 EDT
Created attachment 298414 [details]
wpa_supplicant

/etc/sysconfig/wpa_supplicant

Note that there were no messages related to wpa_supplicant that appeared in
/var/log/messages at the time the attempt was made to start the daemon.
Comment 2 Mike C 2008-03-18 12:27:24 EDT
This test was with rawhide fully up to date as of 18th March 2008 1500 UTC

With wpa_supplicant started manually (and NetworkManager stopped of course) the
wireless connection runs in a normal and stable fashion. It is only the
wpa_supplicant daemon that will not start.
Comment 3 Dan Williams 2008-03-18 14:16:06 EDT
If you are using a static network configuration with the supplicant and you want
the supplicant to start at boot time, please:

chkconfig wpa_supplicant on

it is not set to start up automatically because not everone has/needs WPA
connectivity.

Comment 4 Mike C 2008-03-18 14:27:30 EDT
I was not using static address - I normally run wpa_supplicant to start the
wireless connection, and then dhclient to get an address - this is my typical
way of working with wireless laptops, and it allows me to set it up so that I
have control over the wireless AP that the machine connects to, e.g. to a
different AP at home and at work (by adding network blocks to the config file),
and requires no intervention during the boot and login phase.  This allows the
non-expert user to be free of having to use NetworkManager to select networks.
The easiest way is to run the wpa_supplicant daemon as a service that starts by
default at boot, and then start dhclient in rc.local.

In this case "chkconfig wpa_supplicant on" will fail at next boot, since service
"wpa_supplicant start" does not work whilst the machine is running anyway.

Hence it is essential to get this working for f9. 
Comment 5 Mike C 2008-03-18 14:31:01 EDT
I have re-opened this as it is a bug that needs fixing. It should normally be
possible to start wpa_supplicant either manually or as a daemon. In this case
the daemon does not work.
Comment 6 Dan Williams 2008-03-18 14:47:26 EDT
So if you want supplicant startup on F9 here's what you do:

1) chkconfig wpa_supplicant on
2) Remove "-u" from /etc/sysconfig/wpa_supplicant
3) set up your wpa_supplicant.conf for your network

this isn't a bug; that's simply what you need to do since you are manually
configuring the supplicant.
Comment 7 Mike C 2008-03-18 14:59:11 EDT
I removed the -u flag from /etc/sysconfig/wpa_supplicant/ and then tried again.
i.e. exactly as you list in comment #6
It fails to start the supplicant during boot.

I had already set up the wpa_supplicant.conf for my networks... and indeed this
file is already used with the manual start of the supplicant.

Just to clarify - in my initial comments above I said:
"Actual results:
Terminal output is
Starting wpa_supplicant: /etc/wpa_supplicant/wpa_supplicant.conf, -iwlan0,
-Dwextwpa_supplicant: option requires an argument -- f"

After this there is a spew of comments to the terminal including a list of the
paramaters that can be used by wpa_supplicant i.e. usage but then fails to start.

There is then a lockfile in /var/lock/subsys which needs removing - so something
is amiss....

I have done exactly as you say in comment #6 but this does not work on reboot.
Indeed immediately after reboot the same lockfile is there.
If this is not a bug how can I start the wpa_supplicant daemon since I have done
everything I have normally done in the past to run it for F8?
Comment 8 Dan Williams 2008-03-18 15:08:34 EDT
Ah sorry; one more thing you will have to do is to change your
/etc/sysconfig/wpa_supplicant file to include the path to the logfile (which is
already fixed in wpa_supplicant-0.6.3-5.fc9 if you have not already edited that
config file).

You have two options then:

1) remove the -f option from /etc/sysconfig/wpa_supplicant
2) add "/var/log/wpa_supplicant.log" after the -f option in that file

If you have not modified that file before you installed -5.fc9, it should have
updated for you already.  If you did modify that file, then because it's a
config file, you would need to fix it up.
Comment 9 Mike C 2008-03-18 16:30:30 EDT
Perfect - thanks Dan.  I must have missed the documentation about having to add
the log filename. I guess there is a bz I missed?

Changing the line:
OTHER_ARGS="-f"
 to
OTHER_ARGS="-f /var/log/wpa_supplicant"
works perfectly.

Apologies for the noise.

Note You need to log in before you can comment on or make changes to this bug.