Bug 437998 - Trying to reuse a download in rhn-download-manager does not work
Trying to reuse a download in rhn-download-manager does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
low Severity low
: ---
: ---
Assigned To: Bryan Kearney
Amy Owens
US=19787
:
Depends On:
Blocks: 446437
  Show dependency treegraph
 
Reported: 2008-03-18 12:27 EDT by James Bowes
Modified: 2013-01-10 04:58 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 16:22:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2008-03-18 12:27:09 EDT
rhn-download-manager server side has logic to check your csv against what is in
the db and, if one of your downloads already exists in the db but is just
disabled, reuse that row. This logic causes ISEs. (the row seems to be inserted
again, rather than updated, and with missing columns)
Comment 1 Amy Owens 2008-03-19 08:06:23 EDT
added user story to accepted backlog
Comment 2 James Bowes 2008-05-20 13:08:32 EDT
To test:
 * Get the list of downloads for a channel:
   rhn-download-manager --server webdev --list --show-all rhel-i386-server-5 -o
my.csv
   (make sure at least one of these isos actually exists on the filer. if not,
    get jbowes to copy it over.)
 * Remove all of the existing lines except the iso that actually exists.
 * for that iso, set it to be disabled by changing the download type field from 
  'iso' to 'disabled'
 * Upload this info to the server:
   rhn-download-manager --server webdev --upload my.csv
   (you should not get a 500 error here)
 * just for fun, try with --commit as well.
Comment 3 Amy Owens 2008-05-21 14:36:47 EDT
so now in dev when i click on the iso I get a 500 error-- shouldn't it just not
display...
https://rhn.webdev.redhat.com/download/1211395511/c3f06883ba702ee90ee14e1a45e1735214b78e55/5036675/24993/rhn/isos/RHEL5.1/rhel-i386-server-5/rhel-5.1-server-source-disc1.iso
Comment 4 James Bowes 2008-05-22 11:40:41 EDT
500 error should be fixed. (x-repcon was disabled on the proxy)

So, regarding reusing a download, the only thing you can really change is if its
an iso, or disabled. if you change anything else, if makes a new row. This is
why the link to source disc 1 still shows up, because the db contains a new row
for the Amy source disc, which is properly disabled.
Comment 5 Amy Owens 2008-05-23 09:16:55 EDT
ok looks good
Comment 6 Amy Owens 2008-05-23 09:20:30 EDT
disabled and put back to iso-- disc 1... 
Comment 7 Grant Gainey 2008-06-13 11:56:49 EDT
verified

Note You need to log in before you can comment on or make changes to this bug.