Bug 438005 - NameError: global name 'reqs' is not defined
NameError: global name 'reqs' is not defined
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 13:18 EDT by James Laska
Modified: 2013-09-02 02:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-24 14:59:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (406.73 KB, text/plain)
2008-03-18 13:18 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-03-18 13:18:57 EDT
Description of problem:

Traceback when manually installing on a ppc IBM power5 fails when attempting to
"Remove all partitions"

Version-Release number of selected component (if applicable):

anaconda-11.4.0.54-1

How reproducible:
100%

Steps to Reproduce:
1. Start install
2. At partitioning screen, select "Remove all partitions"
3. Deselect Encryption
4. Click Next
  
Actual results:
anaconda 11.4.0.54 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/autopart.py", line 87, in bootRequestCheck
    for req in reqs:
  File "/usr/lib/anaconda/autopart.py", line 1057, in doPartitioning
    ret = bootRequestCheck(req, diskset)
  File "/usr/lib/anaconda/autopart.py", line 1525, in doAutoPartition
    doPartitioning(diskset, partitions, doRefresh = 0)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1246, in nextClicked
    self.anaconda.dispatch.gotoNext()
NameError: global name 'reqs' is not defined

Expected results:
No traceback

Additional info:

See attachment
Comment 1 James Laska 2008-03-18 13:18:58 EDT
Created attachment 298420 [details]
anacdump.txt
Comment 2 Jeremy Katz 2008-03-18 13:41:22 EDT
Caused by some of the re-jiggering for EFI.  Fixed up in git.
Comment 3 James Laska 2008-03-24 14:58:53 EDT
Verified fixed in anaconda-11.4.0.55-1

Note You need to log in before you can comment on or make changes to this bug.