Bug 438013 - [RHEL5.2] avahi-daemon spewing messages to /var/log/message
[RHEL5.2] avahi-daemon spewing messages to /var/log/message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: avahi (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Lennart Poettering
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 13:45 EDT by Jeff Burke
Modified: 2013-05-06 11:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 14:13:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-03-18 13:45:29 EDT
Description of problem:
 After upgrading to RHEL5.2 I notice the /var/log/messages file is filling up
with messages. There is no reason to be running this daemon on an enterprise sever.

 We should give some guidance to end users why these messages are coming out so
often.

Version-Release number of selected component (if applicable):
 avahi-glib-0.6.16-1.el5
 avahi-qt3-0.6.16-1.el5
 avahi-0.6.16-1.el5
 kdnssd-avahi-0.1.3-0.1.20060713svn.fc6
 avahi-devel-0.6.16-1.el5
 avahi-compat-howl-0.6.16-1.el5
 kdnssd-avahi-devel-0.1.3-0.1.20060713svn.fc6

How reproducible:
 Always
 
Actual results:

Mar 18 12:56:52 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2439 on interface 'eth0.0'
Mar 18 12:58:29 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2483 on interface 'eth0.0'
Mar 18 13:00:07 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2528 on interface 'eth0.0'
Mar 18 13:01:44 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2574 on interface 'eth0.0'
Mar 18 13:03:21 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2615 on interface 'eth0.0'
Mar 18 13:04:59 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2660 on interface 'eth0.0'
Mar 18 13:06:35 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2705 on interface 'eth0.0'
Mar 18 13:08:13 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2748 on interface 'eth0.0'
Mar 18 13:09:51 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2813 on interface 'eth0.0'
Mar 18 13:11:28 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2870 on interface 'eth0.0'
Mar 18 13:13:05 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 2997 on interface 'eth0.0'
Mar 18 13:14:41 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3041 on interface 'eth0.0'
Mar 18 13:16:20 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3085 on interface 'eth0.0'
Mar 18 13:17:57 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3129 on interface 'eth0.0'
Mar 18 13:19:35 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3168 on interface 'eth0.0'
Mar 18 13:19:36 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3168 on interface 'eth0.0'
Mar 18 13:19:36 sc430-01 avahi-daemon[3720]: Invalid legacy unicast query packet.
Mar 18 13:21:14 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3210 on interface 'eth0.0'
Mar 18 13:22:50 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3257 on interface 'eth0.0'
Mar 18 13:24:28 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3299 on interface 'eth0.0'
Mar 18 13:26:06 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3341 on interface 'eth0.0'
Mar 18 13:27:45 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3387 on interface 'eth0.0'
Mar 18 13:29:23 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3428 on interface 'eth0.0'
Mar 18 13:31:01 sc430-01 avahi-daemon[3720]: Recieved repsonse with invalid
source port 3471 on interface 'eth0.0'

Expected results:
System should no spew messages under normal circumstances

Additional info:
FYI in the message:
 avahi-daemon[3720]: Recieved repsonse with invalid source port 2574 on
interface 'eth0.0'
 Both Recieved and repsonse are spelled incorrectly.
Comment 1 Jonathan Blandford 2008-03-20 16:42:42 EDT
AFAIK, avahi wasn't touched in 5.2.  Are we sure this is a regression?  Does
this happen on all machines?
Comment 2 Jeff Burke 2008-03-24 08:54:06 EDT
I did not see this issue with my local system until upgrading to 5.2 Beta. It
may be a side effect from another change, But avahi-daemon is the one yelling
about it.

I have seen it on all the system I have looked at so far.
Comment 3 Lennart Poettering 2008-03-27 14:28:13 EDT
Hmm, these messages are generated because some other mDNS stack in the network
is generating invalid packets. You get one message on every packet. I am not
sure what to do about this...
Comment 4 Jeff Burke 2008-05-15 08:45:18 EDT
I am not sure what the benefit is of the current message is. It is more noise in
the logs. Should the message be modified to also give the ip address of the host
where the packet came from. This may help in finding out why a response with an
invalid source port was sent?
Comment 5 RHEL Product and Program Management 2008-05-15 08:55:44 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 9 RHEL Product and Program Management 2008-09-19 17:53:18 EDT
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 10 Fedora Update System 2008-12-14 14:49:30 EST
avahi-0.6.22-12.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/avahi-0.6.22-12.fc10
Comment 11 Fedora Update System 2008-12-17 19:36:36 EST
avahi-0.6.22-12.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update avahi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11351
Comment 12 Fedora Update System 2009-01-07 04:33:09 EST
avahi-0.6.22-12.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Andrew 2009-04-28 08:25:45 EDT
(In reply to comment #12)
> avahi-0.6.22-12.fc10 has been pushed to the Fedora 10 stable repository.  If
> problems still persist, please make note of it in this bug rep

problem still persist

Apr 28 13:01:27 powickks1 avahi-daemon[3163]: Invalid legacy unicast query packet.
Apr 28 13:01:27 powickks1 avahi-daemon[3163]: Invalid legacy unicast query packet.
Apr 28 13:01:28 powickks1 avahi-daemon[3163]: Invalid legacy unicast query packet.
Apr 28 13:01:28 powickks1 avahi-daemon[3163]: Received response from host 10.14.132.4 with invalid source port 58961 on interface 'eth2.0'
Apr 28 13:01:29 powickks1 avahi-daemon[3163]: Received response from host 10.14.132.4 with invalid source port 58961 on interface 'eth2.0'
Apr 28 13:01:31 powickks1 avahi-daemon[3163]: Received response from host 10.14.132.4 with invalid source port 58961 on interface 'eth2.0'
Apr 28 13:01:35 powickks1 avahi-daemon[3163]: Received response from host 10.14.132.4 with invalid source port 58961 on interface 'eth2.0'
Apr 28 13:01:43 powickks1 avahi-daemon[3163]: Received response from host 10.14.132.4 with invalid source port 58961 on interface 'eth2.0'
Apr 28 13:01:59 powickks1 avahi-daemon[3163]: Received response from host 10.14.132.4 with invalid source port 58961 on interface 'eth2.0'
Apr 28 13:02:31 powickks1 avahi-daemon[3163]: Received response from host 10.14.132.4 with invalid source port 58961 on interface 'eth2.0'
Comment 22 errata-xmlrpc 2009-06-22 14:13:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1119.html
Comment 23 Lennart Poettering 2009-07-23 08:58:08 EDT
Avahi now logs the IP address and everything as suggested in #4. I am strictly against removing these log messages altogether, given that they point to an existing error. I am not sure what else we should be doing.

Note You need to log in before you can comment on or make changes to this bug.