Bug 438014 - [RHEL5.2] net-tools issue with dbus and netplugd.
[RHEL5.2] net-tools issue with dbus and netplugd.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.2
All Linux
low Severity high
: rc
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 13:51 EDT by Jeff Burke
Modified: 2008-03-28 17:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 17:27:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-03-18 13:51:18 EDT
Description of problem:
 Unable to do a service network stop and service network start successfully
after booting.

Version-Release number of selected component (if applicable):
 RHEL5.2-Server-20080313.0

How reproducible:
 Always

Steps to Reproduce:
1. service network stop
2. service network start
  
Actual results:
 The start will fail because dhclient is already running. It was restarted by
netplugd over dbus.

Expected results:
 Should work the same way it did in RHEL5.1

Additional info:
Comment 1 Bill Peck 2008-03-18 13:54:14 EDT
The difference here seems that we are starting netplugd by default now.  Seems
netplugd shouldn't monitor an interface if its not configured to.
Comment 2 Radek Vokal 2008-03-20 10:02:13 EDT
Hi Bill, are you sure that this worked before. I'm not able to see the problem
you are experiencing. The only change which was done in netplugd init script is
the following shift of network test to start section

--- net-tools-1.60/netplug-1.2.9/scripts/rc.netplugd.old	2007-06-08
13:03:45.000000000 +0200
+++ net-tools-1.60/netplug-1.2.9/scripts/rc.netplugd	2007-06-08
13:04:01.000000000 +0200
@@ -17,11 +17,6 @@
 # Source networking configuration.
 . /etc/sysconfig/network
 
-# Check that networking is up.
-[ ${NETWORKING} = "no" ] && exit 0
-
-[ -x /sbin/netplugd ] || exit 0
-
 if [ -f /etc/sysconfig/netplugd ]; then
     . /etc/sysconfig/netplugd
 fi
@@ -30,6 +25,8 @@
 case "$1" in
   start)
 	# Start daemon.
+	[ ${NETWORKING} = "no" ] && exit 1
+	[ -x /sbin/netplugd ] || exit 1
 	echo -n $"Starting network plug daemon: "
 	daemon /sbin/netplugd ${NETPLUGDARGS} -p /var/run/netplugd.pid
 	RETVAL=$?
@@ -57,7 +54,7 @@

Comment 3 Jeff Burke 2008-03-20 10:14:28 EDT
Steps to reproduce:
 Install RHEL5.2-Server-20080313.0. Log into the gnome (Start X)

 service netplugd start

 service network stop

 Service network start

 That should do it. Note on my system here netplugd was started or added to
checkconfig "on" by something/someone other then me.

 I have reproduced this on a second system here.

Jeff
Comment 6 Jeff Burke 2008-03-27 13:59:19 EDT
   It was set to "on" in my serviceconf and would start up automatically on my
desktop. I specifically did not turn it on. So either it is on by default or
another service enabled it.

   My desktop is the only place I run RHEL5.2 client. So I don't have a lot of
data points.

Comment 7 Bill Nottingham 2008-03-28 00:06:07 EDT
I just did a test install of 5.2 snapshot 3 - netplugd is not started by default.
Comment 8 Jeff Burke 2008-03-28 07:42:36 EDT
   That is a great data point. It may not be as big of a issue in the field. I
was wondering if you were able to duplicate it with the steps I put into Comment #3

Comment 9 Bill Nottingham 2008-03-28 16:42:18 EDT
I can duplicate the issue, but I can also duplicate it with the GA versions of
net-tools and initscripts.

Frankly, I think this is an unsupported configuration, similarly to attempting
'service network restart' while NetworkManager is running; it's intentionally
enabling conflicting services.

Now, if something is causing netplugd to be enabled by default, we need to fix
that. But without reproducing that, I can't say what the fix would be.

Jeff: does 'chkconfig netplugd reset' disable the service for you?

Can you reproduce it being enabled across other installations? If so, may need a
dump of the packages that you're installing.
Comment 10 Jeff Burke 2008-03-28 16:54:17 EDT
Jeff: does 'chkconfig netplugd reset' disable the service for you?
 - Yes it did disable it.

I have not duplicated it with out manually starting netplugd. I am at a loss as
to how netplugd was enabled. It was very coincidental to my yum update to
RHEL5.2 beta from U1.

Bill: If you want to close this as NOTABUG since I can't duplicate it on a
RHEL5.2 install. Or do you think a kb article in this case would be a safe way
to go?
Comment 11 Bill Nottingham 2008-03-28 17:27:49 EDT
Not sure aboug a kb article; if we did, we'd need one for NetworkManager too.

Note You need to log in before you can comment on or make changes to this bug.