Bug 438054 - compiz startup causes X server to segfault on Fedora 9 alpha
compiz startup causes X server to segfault on Fedora 9 alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
NeedsRetesting
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 16:19 EDT by Paul Walmsley
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 07:50:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Walmsley 2008-03-18 16:19:34 EDT
Description of problem:
Clicking 'Enable Desktop Effects' on Fedora 9 alpha causes X server to segfault
and die on IBM Thinkpad T61 8897CTO with Intel X3100 integrated graphics.  X log
file shows the following:

compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

Backtrace:
0: X(xf86SigHandler+0x65) [0x476095]
1: /lib64/libc.so.6 [0x38c4a32000]
2: /usr/lib64/xorg/modules/extensions//libglx.so [0x2aaaaaf536c0]
3: /usr/lib64/xorg/modules/extensions//libglx.so [0x2aaaaaf548a1]
4: /usr/lib64/xorg/modules/extensions//libglx.so [0x2aaaaaf2204c]
5: /usr/lib64/xorg/modules/extensions//libglx.so [0x2aaaaaf211a2]
6: /usr/lib64/xorg/modules/extensions//libglx.so [0x2aaaaaf25180]
7: X [0x5030b7]
8: X(Dispatch+0x2e7) [0x444827]
9: X(main+0x44a) [0x42c61a]
10: /lib64/libc.so.6(__libc_start_main+0xf4) [0x38c4a1e2b4]
11: X(FontFileCompleteXLFD+0x281) [0x42b9d9]

Fatal server error:
Caught signal 11.  Server aborting

Version-Release number of selected component (if applicable):
Fedora 9 alpha

How reproducible:
Log in via text console.  Start X with 'startx'.  Select System menu -
Preferences - Look and Feel - Desktop Effects.  Click 'Enable Desktop Effects'.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
The X server should not segfault.

Additional info:
Comment 1 Will Woods 2008-03-18 16:51:53 EDT
Have you updated this machine since installing F9a? Similar bugs to this were fixed recently (in the past 
couple of weeks).

Could you make sure your system is updated, retest, and include the version number of the following 
packages:
compiz, kernel, xorg-x11-drv-i810, xorg-x11-server-Xorg

Thanks!
Comment 2 Paul Walmsley 2008-03-21 12:53:48 EDT
Thanks, I will try this with Fedora 9 beta.
Comment 3 Matěj Cepl 2008-03-21 18:13:00 EDT
Let us know then.
Comment 4 Jesse Keating 2008-04-06 09:50:02 EDT
We recently fixed some glx crashes.  Please be sure that this doesn't happen
with xorg-x11-server-1.4.99.901-17.20080401.fc9 or later.
Comment 5 Jon Stanley 2008-04-18 07:50:51 EDT
I can't reproduce this any more - closing

xorg-x11-server-common-1.4.99.901-22.20080415.fc9.x86_64

Note You need to log in before you can comment on or make changes to this bug.