Bug 438077 - plugin SEGV
plugin SEGV
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 17:43 EDT by David Woodhouse
Modified: 2008-04-17 14:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 14:16:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error log from jvm (68.38 KB, text/plain)
2008-03-18 17:43 EDT, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2008-03-18 17:43:55 EDT
When pointing the java plugin at
http://java.sun.com/applets/jdk/1.4/demo/applets/BarChart/example1.html it fails.

This was working a little while ago with java-1.7.0-icedtea-plugin (on an
otherwise F8 system). Now it fails thus...

GCJ PLUGIN: thread 0x1002bf20: NP_Initialize
GCJ PLUGIN: thread 0x1002bf20: plugin_test_appletviewer
GCJ PLUGIN: thread 0x1002bf20: plugin_test_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: NP_Initialize: using
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/ppc/../../bin/pluginappletviewer
GCJ PLUGIN: thread 0x1002bf20: NP_Initialize return
GCJ PLUGIN: thread 0x1002bf20: GCJ_New
GCJ PLUGIN: thread 0x1002bf20: plugin_data_new
GCJ PLUGIN: thread 0x1002bf20: plugin_data_new return
GCJ PLUGIN: thread 0x1002bf20: plugin_get_documentbase
GCJ PLUGIN: thread 0x1002bf20: plugin_get_documentbase return
GCJ PLUGIN: thread 0x1002bf20: GCJ_New: creating input fifo:
/home/dwmw2/.gcjwebplugin/gcj-instance-9333-0-appletviewer-to-plugin
GCJ PLUGIN: thread 0x1002bf20: GCJ_New: created input fifo:
/home/dwmw2/.gcjwebplugin/gcj-instance-9333-0-appletviewer-to-plugin
GCJ PLUGIN: thread 0x1002bf20: GCJ_New: creating output fifo:
/home/dwmw2/.gcjwebplugin/gcj-instance-9333-0-plugin-to-appletviewer
GCJ PLUGIN: thread 0x1002bf20: GCJ_New: created output fifo:
/home/dwmw2/.gcjwebplugin/gcj-instance-9333-0-plugin-to-appletviewer
GCJ PLUGIN: thread 0x1002bf20: plugin_start_appletviewer
GCJ PLUGIN: thread 0x1002bf20: plugin_start_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: GCJ_New: got confirmation that appletviewer is
running.
GCJ PLUGIN: thread 0x1002bf20: plugin_create_applet_tag
GCJ PLUGIN: thread 0x1002bf20: plugin_create_applet_tag return
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-9333-0
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: tag
http://java.sun.com/applets/jdk/1.4/demo/applets/BarChart/example1.html <EMBED
CODEBASE="." CODE="BarChart.class" HEIGHT="130" WIDTH="250" ><PARAM NAME="title"
VALUE="Performance"><PARAM NAME="columns" VALUE="4"><PARAM NAME="orientation"
VALUE="horizontal"><PARAM NAME="scale" VALUE="5"><PARAM NAME="c1_label"
VALUE="Q1"><PARAM NAME="c1" VALUE="10"><PARAM NAME="c1_color"
VALUE="blue"><PARAM NAME="c1_style" VALUE="striped"><PARAM NAME="c2_label"
VALUE="Q2"><PARAM NAME="c2" VALUE="20"><PARAM NAME="c2_color"
VALUE="green"><PARAM NAME="c2_style" VALUE="solid"><PARAM NAME="c3_label"
VALUE="Q3"><PARAM NAME="c3" VALUE="5"><PARAM NAME="c3_color"
VALUE="magenta"><PARAM NAME="c3_style" VALUE="striped"><PARAM NAME="c4_label"
VALUE="Q4"><PARAM NAME="c4" VALUE="30"><PARAM NAME="c4_color"
VALUE="yellow"><PARAM NAME="c4_style" VALUE="solid"></EMBED>
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: GCJ_New return
GCJ PLUGIN: thread 0x1002bf20: NP_GetValue
GCJ PLUGIN: thread 0x1002bf20: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x1002bf20: NP_GetValue return
GCJ PLUGIN: thread 0x1002bf20: GCJ_GetValue
GCJ PLUGIN: thread 0x1002bf20: GCJ_GetValue: returning TRUE for NeedsXEmbed.
GCJ PLUGIN: thread 0x1002bf20: GCJ_GetValue return
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow: setting window.
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-9333-0
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: handle 35675198 width 250 height 130
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow return
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow: window already exists.
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow: window width changed.
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-9333-0
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: width 250
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow: window height changed.
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-9333-0
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: height 130
GCJ PLUGIN: thread 0x1002bf20: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow return
  PIPE: appletviewer wrote: running
  PIPE: appletviewer read: instance-9333-0
  PIPE: appletviewer read: tag
http://java.sun.com/applets/jdk/1.4/demo/applets/BarChart/example1.html <EMBED
CODEBASE="." CODE="BarChart.class" HEIGHT="130" WIDTH="250" ><PARAM NAME="title"
VALUE="Performance"><PARAM NAME="columns" VALUE="4"><PARAM NAME="orientation"
VALUE="horizontal"><PARAM NAME="scale" VALUE="5"><PARAM NAME="c1_label"
VALUE="Q1"><PARAM NAME="c1" VALUE="10"><PARAM NAME="c1_color"
VALUE="blue"><PARAM NAME="c1_style" VALUE="striped"><PARAM NAME="c2_label"
VALUE="Q2"><PARAM NAME="c2" VALUE="20"><PARAM NAME="c2_color"
VALUE="green"><PARAM NAME="c2_style" VALUE="solid"><PARAM NAME="c3_label"
VALUE="Q3"><PARAM NAME="c3" VALUE="5"><PARAM NAME="c3_color"
VALUE="magenta"><PARAM NAME="c3_style" VALUE="striped"><PARAM NAME="c4_label"
VALUE="Q4"><PARAM NAME="c4" VALUE="30"><PARAM NAME="c4_color"
VALUE="yellow"><PARAM NAME="c4_style" VALUE="solid"></EMBED>
  PIPE: appletviewer read: instance-9333-0
  PIPE: appletviewer read: handle 35675198 width 250 height 130
GCJ PLUGIN: thread 0x1002bf20: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x1002bf20: plugin_in_pipe_callback: setting status starting
applet...
  PIPE: plugin read: status starting applet...
GCJ PLUGIN: thread 0x1002bf20: plugin_in_pipe_callback return
  PIPE: appletviewer wrote: status starting applet...
  PIPE: appletviewer read: instance-9333-0
  PIPE: appletviewer read: width 250
  PIPE: appletviewer read: instance-9333-0
  PIPE: appletviewer read: height 130
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  Internal Error (os_linux_zero.cpp:144), pid=9414, tid=1867568304
#  Error: caught unhandled signal 11
#
# Java VM: IcedTea Core VM (1.6.0-b06 interpreted mode linux-ppc)
# An error report file with more information is saved as:
# /home/dwmw2/working/eximconf/infradead/hs_err_pid9414.log
#
# If you would like to submit a bug report, please visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
GCJ PLUGIN: thread 0x1002bf20: plugin_out_pipe_callback
GCJ PLUGIN: thread 0x1002bf20: plugin_out_pipe_callback: appletviewer has stopped.
GCJ PLUGIN: thread 0x1002bf20: plugin_out_pipe_callback return
GCJ PLUGIN: thread 0x1002bf20: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x1002bf20: appletviewer has stopped.
GCJ PLUGIN: thread 0x1002bf20: plugin_in_pipe_callback return
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow: window already exists.
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow: appletviewer is not running.
GCJ PLUGIN: thread 0x1002bf20: GCJ_SetWindow return
Comment 1 David Woodhouse 2008-03-18 17:43:55 EDT
Created attachment 298455 [details]
error log from jvm
Comment 2 David Woodhouse 2008-03-18 18:03:56 EDT
I went back to java-1.7.0-icedtea-1.7.0.0-0.29.b24.fc9 to test, and it fails
there similarly. I'll try an even older version; I'm sure it was working once.
Comment 3 David Woodhouse 2008-03-18 18:30:05 EDT
Looks like it was 1.7.0.0-0.22.b23.snapshot.fc9 which I used to have installed
on F8 (which iirc was working fine), but that also fails similar to the above. 
Comment 4 David Woodhouse 2008-03-19 09:26:52 EDT
Hm, this works on two other machines (32-bit and 64-bit) running rawhide. Just
not on my main laptop, which had various issues with its upgrade (like glibc
going missing, most of GNOME being broken and having to be removed and
reinstalled). I assume it's a local problem.
Comment 5 David Woodhouse 2008-03-21 06:46:45 EDT
Indeed it was a local problem -- I had two lines in /etc/hosts which started

::1  localhost.ipv6 localhost.localdomain localhost localhost.ipv6
localhost.localdomain localhost ...

and went on like that for about 150KiB each. How they got there, I have no idea.
You should be able to reproduce this, and it might even be possible that a
malicious remote site could do it too, with _many_ PTR records for a single address.
Comment 6 Lillian Angel 2008-04-17 14:16:51 EDT
This is working fine for me (using java-1.6.0-openjdk), even with the PTR records.

Closing.
Comment 7 David Woodhouse 2008-04-17 14:24:01 EDT
What PTR records did you set up? Did you test with an /etc/hosts file like the
one I described? It was purely speculation that it might be possible to trigger
it with PTR records.

Note You need to log in before you can comment on or make changes to this bug.