Bug 438094 - [zh-TW] Missing translations on start menu.
[zh-TW] Missing translations on start menu.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-release-notes (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
: i18n, Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 19:58 EDT by Caius Chance
Modified: 2013-01-09 23:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 07:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New file in ./fedora-release-notes-8.90/about-fedora-8.90/ (1.05 KB, application/octet-stream)
2008-03-31 22:19 EDT, Caius Chance
no flags Details
New file in ./fedora-release-notes-8.90/about-fedora-8.90/about-fedora/zh_TW (5.04 KB, text/xml)
2008-03-31 22:58 EDT, Caius Chance
no flags Details
Patch file of ./fedora-release-notes-8.90/about-fedora-8.90/about-gnome.desktop.patch (816 bytes, text/x-patch)
2008-03-31 23:02 EDT, Caius Chance
no flags Details

  None (edit)
Description Caius Chance 2008-03-18 19:58:38 EDT
Description of problem:
There are two missing translation on the start menu.

Version-Release number of selected component (if applicable):
gnome-desktop-2.22.0-1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Install Chinese Support with pirut or yum.
2. Enter gnome desktop with zh-TW (Traditional Chinese / 中文(中華民國) ).
3. Click on start menu '系統'.
4. Check out the items.
  
Actual results:
There are two items that are not translated:
"About Fedora"
"About This Computer"

Expected results:
There should be translated into something similar:
"關於 Fedora"
"關於這檯電腦" / "關於這檯機器" / "關於本電腦" / "關於本機器" / "關於本機"

Additional info:
Translation might consistent to current ones.
Comment 1 Chester Cheng 2008-03-18 20:55:23 EDT
Hey Caius,

During the past 3 years, I've been trying to become a GNome translator, but
hasn't gotten any reply yet.  Do you have access to their repo?  I can translate
the file and maybe you could upload for me.

Cheers,
Chester
Comment 2 Caius Chance 2008-03-18 21:02:23 EDT
Let me try to apply to be Gnome translator and see why.
Comment 3 Caius Chance 2008-03-18 23:15:08 EDT
Chester, please let me know your progress of reapplying for account. Thanks.
Comment 4 Ray Strode [halfline] 2008-03-19 09:50:31 EDT
So in these cases, they aren't gnome strings, but fedora specific ones.  We'll
need to patch it manually downstream.
Comment 5 Caius Chance 2008-03-24 21:05:31 EDT
Searched gnome-desktop source directory. The above strings are not found.
Comment 6 Caius Chance 2008-03-30 21:13:26 EDT
Hi Chester, which package you think the strings are located?
Comment 7 Matthias Clasen 2008-03-31 10:22:05 EDT
[mclasen@localhost Desktop]$ rpm -qf /usr/share/applications/about-fedora.desktop 
fedora-release-notes-8.90-1.noarch
[mclasen@localhost Desktop]$ rpm -qf
/usr/share/applications/about-this-computer.desktop 
gnome-system-monitor-2.22.0-1.fc9.i386
[mclasen@localhost Desktop]$ 
Comment 8 Matthias Clasen 2008-03-31 10:23:29 EDT
Here is one more I'd like to point you to:

/usr/share/gnome-background-properties/desktop-backgrounds-waves.xml

in the desktop-backgrounds package. The "Waves" name would benefit from being
translated.
Comment 9 Ray Strode [halfline] 2008-03-31 13:30:41 EDT
Note, in the gnome-system-monitor case it's something we patched in, so it's
still not an upstream issue.
Comment 10 Caius Chance 2008-03-31 22:19:15 EDT
Created attachment 299801 [details]
New file in ./fedora-release-notes-8.90/about-fedora-8.90/
Comment 11 Caius Chance 2008-03-31 22:58:54 EDT
Created attachment 299815 [details]
New file in ./fedora-release-notes-8.90/about-fedora-8.90/about-fedora/zh_TW
Comment 12 Caius Chance 2008-03-31 23:02:29 EDT
Created attachment 299816 [details]
Patch file of ./fedora-release-notes-8.90/about-fedora-8.90/about-gnome.desktop.patch
Comment 13 Caius Chance 2008-03-31 23:03:59 EDT
Hi Ray, would you possible to patch the local tree, also submit the changes to
upstream please?
Comment 14 Will Woods 2008-03-31 23:49:37 EDT
The "About This Computer" item is my doing - see bug 437997. 

Which string would you recommend for the zh-TW version of "About this Computer"?
Comment 15 Caius Chance 2008-04-01 00:43:23 EDT
Hi Ray, could this bug package be changed to fedora-release-notes for maintainer
to patch that please? (BTW as last comment, the "About This Computer" item is
tracked by bug# 437997.)
Comment 16 Paul W. Frields 2008-04-04 09:18:30 EDT
Caius and Chester,

These strings are all translatable as part of the normal Fedora process, as they
have been for several releases now.  When translating work where Fedora is the
upstream, you can use the established Fedora processes to make updates.  Please
refer to the Translation Quick Start Guide at
http://docs.fedoraproject.org/translation-quick-start-guide/en_US/ for
instructions on how to get involved, using Transifex
(http://translate.fedoraproject.org/) or Fedora Docs CVS repositories.

I'll get this stuff into zh_TW for the about-fedora module, but where possible I
recommend you contribute directly to the Fedora L10N project.

You can also file a bug to get a zh_TW component added for the Fedora
Localization product.
Comment 17 Paul W. Frields 2008-04-04 09:19:38 EDT
I went ahead and filed the zh_TW component bug:
https://bugzilla.redhat.com/show_bug.cgi?id=440663 
Comment 18 Paul W. Frields 2008-04-12 14:42:11 EDT
Caius, Chester,

Have you joined the Translation Projectand read the suggested information? 
There's quite a bit of translatable strings beyond just the menu entry for About
Fedora.  There are still a few days left before we pick up those strings for the
final version of Fedora 9.
Comment 19 Paul W. Frields 2008-04-12 15:53:26 EDT
All the about-fedora information has been imported into the PO file in Docs CVS.
 This should make it to Fedora 9 without a problem.  Clearing the blocker.
Comment 20 Chester Cheng 2008-04-13 22:08:32 EDT
Paul, we don't have resources for zh-TW at the moment.  Maybe aiming on Fedora
10 would be realistic.
Comment 21 Paul W. Frields 2008-04-14 07:02:30 EDT
Sure, I definitely understand not having enough resources to do more translation
work for Fedora 9. :-)  Now is a very good time for Caius to join up with the
Fedora L10N crew and get comfortable with their processes for the next release
cycle.

http://fedoraproject.org/wiki/L10N/Join
Comment 22 Caius Chance 2008-04-14 19:53:08 EDT
Though I would like to join up with the translation at some points, I am in
engineering but is not in Fedora L10N. I filed this bug because I am Traditional
Chinese user.

> Sure, I definitely understand not having enough resources to do more translation
> work for Fedora 9. :-)  Now is a very good time for Caius to join up with the
> Fedora L10N crew and get comfortable with their processes for the next release
> cycle.
> 
> http://fedoraproject.org/wiki/L10N/Join


Note You need to log in before you can comment on or make changes to this bug.