Bug 438144 - named search query error - Can't use qa_whiteboard as a field name.
named search query error - Can't use qa_whiteboard as a field name.
Status: CLOSED DUPLICATE of bug 443140
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: Noura El hawary
:
Depends On: 443140
Blocks: RHBZ30UpgradeTracker
  Show dependency treegraph
 
Reported: 2008-03-19 08:42 EDT by James Laska
Modified: 2013-09-02 02:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 13:57:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-03-19 08:42:50 EDT
Description of problem:

Using a saved named query results in an error (see below).

Version-Release number of selected component (if applicable):
bugzilla 3.2

How reproducible:
100%

Steps to Reproduce:
1. Go to https://bz-web2-test.devel.redhat.com
2. Login using a valid bz user/pass
3. Click on a named public search in your page footer
  
Actual results:
Red Hat Bugzilla has suffered an internal error. Please save this page and send
it to bugzilla-owner@redhat.com with details of what you were doing at the time
this message appeared.

URL:
https://bz-web2-test.devel.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=rhel-5.2.0%20installer%20ON_QA
Can't use qa_whiteboard as a field name.

Expected results:
This page ...
https://bugzilla.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=rhel-5.2.0%20installer%20ON_QA

Additional info:
Comment 1 David Lawrence 2008-03-19 09:15:51 EDT
The {qa,devel,internal}_whiteboard fields have been converted to take advantage
of  custom field support in the new Bugzilla. As a result the column names for
the fields are now prefixed with cf_*. So the field names will need to be
cf_{qa,devel,internal}_whiteboard. I will need to create a script that will fix
everyone's stored queries to make this transition transparent to end users.
Comment 2 Kevin Baker 2008-04-14 22:54:19 EDT
not milestone 3, but definitely a final blocker
Comment 3 David Lawrence 2008-05-12 13:57:47 EDT

*** This bug has been marked as a duplicate of 443140 ***

Note You need to log in before you can comment on or make changes to this bug.