Bug 438155 - oocalc can't open file when cups not working
oocalc can't open file when cups not working
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 09:54 EDT by Alexander Todorov
Modified: 2008-03-19 10:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 10:13:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output when CUPS is running (2.32 MB, text/plain)
2008-03-19 09:55 EDT, Alexander Todorov
no flags Details
strace output when CUPS is stopped (bzipped) (111.13 KB, application/x-bzip2)
2008-03-19 10:00 EDT, Alexander Todorov
no flags Details
sample file (spreadsheet) (6.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-03-19 10:02 EDT, Alexander Todorov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 34140 None None None Never
OpenOffice.org 65739 None None None Never

  None (edit)
Description Alexander Todorov 2008-03-19 09:54:17 EDT
Description of problem:
Trying to open a file maxouts the CPU and doesn't proceed to success (not
failure) when CUPS not running. This happens with one particular file.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.3.0-6.4.el5
openoffice.org-xsltfilter-2.3.0-6.4.el5
openoffice.org-writer-2.3.0-6.4.el5
openoffice.org-graphicfilter-2.3.0-6.4.el5
openoffice.org-draw-2.3.0-6.4.el5
openoffice.org-langpack-bg_BG-2.3.0-6.4.el5
openoffice.org-calc-2.3.0-6.4.el5
openoffice.org-math-2.3.0-6.4.el5
openoffice.org-impress-2.3.0-6.4.el5


How reproducible:
100% with the sample file

Steps to Reproduce:
1. Stop CUPS
2. Try to open the sample file
3.
  
Actual results:
scalc.bin and rpc.statd max out the CPU (see below) file can't be opened

Expected results:
File is opened.

Additional info:

top output:

Tasks: 141 total,   2 running, 139 sleeping,   0 stopped,   0 zombie
Cpu(s): 11.1%us, 24.8%sy,  0.0%ni, 34.7%id,  0.0%wa,  0.2%hi, 29.2%si,  0.0%st
Mem:   2058608k total,  1844260k used,   214348k free,   212724k buffers
Swap:  2096472k total,        0k used,  2096472k free,  1019616k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
                                                                               
            
 2179 alexx     20   0  587m  48m  34m S   86  2.4   0:08.71 scalc.bin         
                                                                               
            
 2569 rpcuser   15   0 12240  860  696 S   33  0.0  10:28.81 rpc.statd         
                                                                               
            
 3385 alexx     15   0  306m  28m 9.9m R    7  1.4   1:39.34 gnome-terminal    
                                                                               
            
 3108 root      15   0  119m  27m 7916 S    3  1.4   3:16.13 Xorg              
                                                                               
            
 3376 alexx     15   0  736m 156m  25m S    1  7.8   1:24.35 thunderbird-bin
Comment 1 Alexander Todorov 2008-03-19 09:55:29 EDT
Created attachment 298513 [details]
strace output when CUPS is running

Open the file and quit.
Comment 2 Alexander Todorov 2008-03-19 10:00:49 EDT
Created attachment 298514 [details]
strace output when CUPS is stopped (bzipped)

Open the file, wait for some time, then kill OpenOffice.org
What can be seen is sequences of 

[pid  1810] connect(48, {sa_family=AF_INET, sin_port=htons(631),
sin_addr=inet_addr("127.0.0.1")}, 16) = 0
[pid  1810] sendto(48, "POST / HTTP/1.1\r\nContent-Length:"..., 134, 0, NULL,
0) = 134
[pid  1810] sendto(48, "\1\1@\2\0\0\0\1\1G\0\22attributes-charset\0\5"..., 352,
0, NULL, 0) = 352
[pid  1810] select(49, [48], NULL, NULL, {1, 0}) = 1 (in [48], left {1, 0})
[pid  1810] recvfrom(48, "", 2048, 0, NULL, NULL) = 0
[pid  1810] close(48)			= 0
[pid  1810] socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 48
[pid  1810] setsockopt(48, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0
[pid  1810] setsockopt(48, SOL_TCP, TCP_NODELAY, [1], 4) = 0
[pid  1810] fcntl(48, F_SETFD, FD_CLOEXEC) = 0

OOo is connecting to port 631 on localhost and performs HTTP POST.
Comment 3 Alexander Todorov 2008-03-19 10:02:55 EDT
Created attachment 298515 [details]
sample file (spreadsheet)

Original file was created with OOo 2.0 and contained private data.
All of that was deleted down to an empty spreadsheet which still reproduces the
issue. Originally I thought that it may be something content related. strace
outputs are from using this file
Comment 4 Alexander Todorov 2008-03-19 10:04:01 EDT
# netstat -antp 
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address            
State       PID/Program name   
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                  
LISTEN      2548/portmap        
tcp        0      0 192.168.122.1:53            0.0.0.0:*                  
LISTEN      2971/dnsmasq        
tcp        0      0 0.0.0.0:631                 0.0.0.0:*                  
LISTEN      2569/rpc.statd      
tcp        0      0 127.0.0.1:631               127.0.0.1:34069            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:32802            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:58195            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:59224            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:33113            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:37987            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:37990            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:37988            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:34405            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:35185            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:60283            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:37507            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:34179            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:36740            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:58282            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:36268            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:36269            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:37328            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:58591            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:58588            
TIME_WAIT   -                   
tcp        0      0 127.0.0.1:631               127.0.0.1:58589            
TIME_WAIT   -               

netstat output right after killing OOo. Shows that 631 is the port for rcp.statd
Comment 5 Alexander Todorov 2008-03-19 10:06:12 EDT
Note:
I'm not sure if CUPS has something to do with this bug but tried opening the
file while CUPS is running by mistake. Then I found that the issue is
reproduce-able when CUPS is stopped.
Comment 6 Caolan McNamara 2008-03-19 10:08:20 EDT
If the printing setup is broken then OOo will indeed appear broken while waiting
for the printer metrics from cups to do the wysiwyg layout for the selected printer
Comment 7 RHEL Product and Program Management 2008-03-19 10:13:02 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.