Bug 438175 - Error message suggests to use up2date --register on RHEL 5
Error message suggests to use up2date --register on RHEL 5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.1
All Linux
medium Severity low
: rc
: ---
Assigned To: John Matthews
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 11:17 EDT by Jan Pazdziora
Modified: 2008-05-21 10:27 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0360
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-03-19 11:17:39 EDT
Description of problem:

I've run yum check-update on my system. The wording of the error message
suggests to use up2date --register. Maybe this is Satellite specific.

Version-Release number of selected component (if applicable):

# rpm -q yum yum-rhn-plugin
yum-3.0.1-5.el5
yum-rhn-plugin-0.4.3-1.el5

How reproducible:

Tried once.

Steps to Reproduce:
1. Have a system registered to RHN (Satellite), then delete that system on the
WebUI.
2. Run yum check-update on that system.
  
Actual results:

# yum check-update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
There was an error communicating with RHN.
RHN support will be disabled.
Error communicating with server. The message was:

Error Message:
    Please run rhn_register (or up2date --register on Red Hat Enterprise Linux 3
or later)
as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Setting up repositories
No Repositories Available to Set Up
Reading repository metadata in from local files
# rhn_register

Expected results:

It should not mention up2date --register, or it should make it clear that
up2date is RHEL 3 and RHEL 4 only, not RHEL 3 or later, since there is no
up2date on RHEL 5.

Additional info:
Comment 2 John Matthews 2008-03-20 15:00:32 EDT
I think this is a change to Satellite on the backend.

This file, eng/backend/server/rhnHandler.py, sends the referenced error message.




Comment 3 Jan Pazdziora 2008-03-27 10:56:27 EDT
(In reply to comment #2)
> I think this is a change to Satellite on the backend.
> 
> This file, eng/backend/server/rhnHandler.py, sends the referenced error message.

Right.

We might want to fix this in the Satellite ... but then we will still hit the
problem when parented to hosted, we'd need to fix hosted as well. In addition:
do we have enough information in the Satellite code to properly detect client
environment and generate correctly customized error message?

Maybe we could do a change to the client code and override whatever error
message we got from the Satellite/hosted to be correct in our local environment.
So that Satellite/hosted could still generate message which is slightly
confusing (heck, the error message should just holt the error information, not
suggestions what to do about it, that's clearly client tools task) and yum /
yum-rhn-plugin could overwrite it to be correct on RHEL 5.
Comment 5 John Matthews 2008-03-28 21:17:17 EDT
Added a code change to the client which will reword the error message.  

svn rev #167644
Comment 7 Cameron Meadors 2008-04-22 11:04:09 EDT
I now get this error message when now registered:

There was an error communicating with RHN.
RHN support will be disabled.
Error communicating with server. The message was:

Error Message:
        Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Comment 9 errata-xmlrpc 2008-05-21 10:27:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0360.html

Note You need to log in before you can comment on or make changes to this bug.