Bug 438197 - incorrect encoding on show_bug page
incorrect encoding on show_bug page
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: Tony Fu
:
Depends On:
Blocks: RHBZ30UpgradeTracker
  Show dependency treegraph
 
Reported: 2008-03-19 13:21 EDT by Michal Babej
Modified: 2013-07-31 19:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 13:41:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Babej 2008-03-19 13:21:17 EDT
Description of problem:

names on show_bug page appears with incorrect characters

see e.g. Reporter field on
https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=225570
Comment 1 David Lawrence 2008-03-19 13:32:06 EDT
Tony do you mind looking at this?
Comment 2 Tony Fu 2008-03-20 02:09:52 EDT
Dave,

Both client side and server side sql settings look fine and I can use sql client
to get utf8 characters without any problem.  So it shouldn't be a problem of sql
server settings.

I found that bugzilla generated html page on bz-web2-test.devel.redhat.com
didn't include the following <head> information

<meta http-equiv="content-type" content="text/html; charset=UTF-8">.

I guess it causes the utf-8 characters display problem.

Tony
Comment 3 David Lawrence 2008-03-20 12:58:45 EDT
I have tried added <meta http-equiv="content-type" content="text/html;
charset=UTF-8"> to the headers without success.

I also doubled checked the MySQL configuration being used by bz-web2 and it is
correct.

{ mysql_enable_utf8 => 1 }
$self->do("SET NAMES utf8");

I even added which is part of rh_bugzilla_2_18

$self->do("SET CHARACTER SET utf8");

Nothing made the characters appear different.

If I select the data directly from MySQL it looks correct like Tony mentioned:

mysql> SET NAMES utf8;
Query OK, 0 rows affected (0.00 sec)

mysql> select bug_id, profiles.login_name, profiles.realname from longdescs,
profiles where longdescs.who = profiles.userid and longdescs.bug_id = 225570;
+--------+---------------------+----------------+
| bug_id | login_name          | realname       |
+--------+---------------------+----------------+
| 225570 | rbiba@redhat.com    | Radek Bíba    | 
| 225570 | jlieskov@redhat.com | Jan Lieskovsky | 
| 225570 | jhutar@redhat.com   | Jan Hutař     | 
| 225570 | dkovalsk@redhat.com | David Kovalsky | 
| 225570 | rbiba@redhat.com    | Radek Bíba    | 
| 225570 | rbiba@redhat.com    | Radek Bíba    | 
+--------+---------------------+----------------+

Will need to investigate further and may talk to upstream.

Comment 4 Tony Fu 2008-03-25 03:02:48 EDT
Dave,

It seems that the bugzilla code on bz-web2-test has some problems on utf8
support.  I have tried to create a few new users whose real names include
non-english characters and they couldn't be displayed properly.

But I tested these users names on upstream code and the code checked out from
our cvs repository, and there were NO problems on utf8 support.  So I guess utf8
support problem is specific to the bugzilla code we are using on bz-web2-test.


Tony
Comment 5 David Lawrence 2008-03-28 17:18:50 EDT
I found out what is causing this. The perl-DBD-MySQL that we ship with EL5 is
older than the one we ship with EL4-stacks and needs to be updated. Once I
updated to the newer perl-DBD-mysql on bz-web2-test the utf8 chars now look correct.

I have added a ticket to eng-sysadmin@redhat.com to add this newer DBD-mysql to
eso/el5 yum repo.

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=1234287

Dave

Note You need to log in before you can comment on or make changes to this bug.