Bug 438198 - pup - backtrace on repository disabling via Repository Manager
pup - backtrace on repository disabling via Repository Manager
Status: CLOSED DUPLICATE of bug 435840
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 13:24 EDT by Michal Nowak
Modified: 2013-03-07 21:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 16:22:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum config file (649 bytes, text/plain)
2008-03-19 13:24 EDT, Michal Nowak
no flags Details
Our local server is dead this is "OK" from pup POV (32.85 KB, image/png)
2008-03-19 13:33 EDT, Michal Nowak
no flags Details
Unchecking the selected one backtraces immediately (33.98 KB, image/png)
2008-03-19 13:34 EDT, Michal Nowak
no flags Details
backtrace (56.55 KB, image/png)
2008-03-19 13:34 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2008-03-19 13:24:21 EDT
Description of problem:

started pup then I got msg that is not possible to get repomd.xml file (the
rerver is dead AFAIK), then I choose to edit config  file via Repository
Manager, unchecked rhel-5-server and got backtrace

Component: pirut
Summary: TBff145c36 yumRepo.py:348:disablePersistent:AttributeError: 'RhnRepo'
object has no attribute 'cfg'

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/pirut/RepoSelector.py", line 395, in
_repoToggled
    repo.disablePersistent()
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 348, in
disablePersistent
    self.cfg.set(self.id, 'enabled', '0')
AttributeError: 'RhnRepo' object has no attribute 'cfg'

Local variables in innermost frame:
self: rhel-i386-server-5

Version-Release number of selected component (if applicable):
pirut-1.3.28-12.el5

How reproducible:
always

Actual results:
traceback && quit

Expected results:
disabled repo

Additional info:
see attached /etc/yum.conf

It's happening only on this one repo, others are possible to enable/disable.
Comment 1 Michal Nowak 2008-03-19 13:24:21 EDT
Created attachment 298544 [details]
yum config file
Comment 2 Michal Nowak 2008-03-19 13:33:29 EDT
Created attachment 298547 [details]
Our local server is dead this is "OK" from pup POV
Comment 3 Michal Nowak 2008-03-19 13:34:41 EDT
Created attachment 298548 [details]
Unchecking the selected one backtraces immediately
Comment 4 Michal Nowak 2008-03-19 13:34:59 EDT
Created attachment 298549 [details]
backtrace
Comment 5 James Antill 2008-03-19 16:22:01 EDT

*** This bug has been marked as a duplicate of 435840 ***

Note You need to log in before you can comment on or make changes to this bug.