Bug 438199 - NM adds default route on unconnected interface
NM adds default route on unconnected interface
Status: CLOSED DUPLICATE of bug 437338
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 13:34 EDT by David Woodhouse
Modified: 2008-03-19 18:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 18:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2008-03-19 13:34:43 EDT
New install, NetworkManager-0.7.0-0.9.1.svn3440.fc9.ppc

I have two interfaces, one of which is connected and has a working DHCP server;
the other of which is unconnected. 

NetworkManager ignores the default route advertised by the DHCP server and adds
one directly on the unconnected eth1.

[root@electra ~]# ip -4 route                                                  
                                        
90.155.92.192/26 dev eth0  proto kernel  scope link  src 90.155.92.207         
                                        
169.254.0.0/16 dev eth1  proto kernel  scope link  src 169.254.149.162         
                                        
default dev eth1  scope link
Comment 1 Dan Williams 2008-03-19 18:10:41 EDT
-EUPGRADE :)  Try 3476 in rawhide/koji.

*** This bug has been marked as a duplicate of 437338 ***

Note You need to log in before you can comment on or make changes to this bug.