Bug 438254 - When downloading .rpm files options is to save or "run with other..." - no "run with installer" option
When downloading .rpm files options is to save or "run with other..." - no "r...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-19 17:23 EDT by Frank Thingholm
Modified: 2008-03-28 07:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 07:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
attempt to reproduce (51.23 KB, image/png)
2008-03-19 19:05 EDT, Matěj Cepl
no flags Details
Screen dump FF3 after clicking link to .rpm file. (The file seems to be for Fedora 5, but is the newest from Skype and works fine in Fedora 8.) (175.20 KB, image/png)
2008-03-20 00:29 EDT, Frank Thingholm
no flags Details

  None (edit)
Description Frank Thingholm 2008-03-19 17:23:34 EDT
Description of problem:
When downloading a .rpm file (Skype, in this case), no option to "run with
installer" is shown - only "run with other program" and "save" are shown.

Version-Release number of selected component (if applicable):
Rawhide today - and has been so for the last appx. 7 days (haven't tried earlier).

How reproducible:
Every time.

Steps to Reproduce:
1. Click on a .rpm file link on a web page
2. Dialog box appears, options are RUN (with "other program") and SAVE.
3.
  
Actual results:


Expected results:
Dialog box should suggest RUN "with installer".

Additional info:
Unsure where this belongs - Firefox, Gnome, Anaconda or Packaging. Well, here it is.
Comment 1 Matěj Cepl 2008-03-19 19:05:01 EDT
Created attachment 298607 [details]
attempt to reproduce

Actaully I cannot reproduce it now. This is what I get both with FF2 as well as
FF3b4.

Reporter, could elaborate a little bit on your environment? Is this upstream
firefox binary, or firefox from RH package? Could you reproduce it with running


firefox -safe-mode

?
Comment 3 Frank Thingholm 2008-03-20 00:29:29 EDT
Created attachment 298626 [details]
Screen dump FF3 after clicking link to .rpm file.

(The file seems to be for Fedora 5, but is the newest from Skype and works fine in Fedora 8.)
Comment 4 Frank Thingholm 2008-03-20 00:38:58 EDT
It's a clean boot.iso install-from-URL rawhide install made after the 19MAR2008
replication. No updates are available from rawhide, I haven't tried to use the
update menu item in FF.

FF3 reports "3.0b5pre".

Opening terminal windows and running "firefox -safe-mode" makes no difference. A
screen dump would be exactly the same as #3 (which was made with FF started from
GNOME FF icon).

And, yes, BTW, I run GNOME - and selected DANISH language and "dk" keyboard
during install. (I have filed a separate bug about the "dk" keyboard layout
chosen during install not taking effect.)

Comment 6 Frank Thingholm 2008-03-20 02:38:17 EDT
(Dummy comment with "I am providing the requested information for this bug" set.)
Comment 7 Will Woods 2008-03-27 15:17:11 EDT
In this specific case, the server sends the following header:

  Content-Type: application/x-redhat-package-manager

Firefox correctly identifies it as an "RPM package" but doesn't offer
pk-install-file as an application. Tried adding that to the MimeType field in
pk-install-file.desktop but it didn't seem to change anything.

This is firefox in current rawhide.
Comment 8 Matěj Cepl 2008-03-28 07:45:44 EDT
will, did you do all update-mime-database magic?
Comment 9 Matěj Cepl 2008-03-28 07:52:38 EDT
reassigning
Comment 10 Matěj Cepl 2008-03-28 07:54:46 EDT
Just for illustration:

[matej@localhost ~]$ curl -L -I http://www.skype.com/go/getskype-linux-fc7
HTTP/1.1 302 Found
Date: Fri, 28 Mar 2008 11:54:05 GMT
Server: Apache
Set-Cookie: SC=CC=:CCY=:LC=:TM=1206705245:TS=1206705245:TZ=:VER=2/2.0.0.68/;
expires=Sat, 28-Mar-09 11:54:05 GMT; path=/; domain=.skype.com;
Location: http://download.skype.com/linux/skype-2.0.0.68-fc5.i586.rpm
Vary: Accept-Encoding,User-Agent
Content-Type: text/html; charset=utf-8
Content-Language: en

HTTP/1.1 200 OK
Server: nginx/0.5.35
Date: Fri, 28 Mar 2008 12:03:54 GMT
Content-Type: application/x-redhat-package-manager
Content-Length: 14871058
Last-Modified: Thu, 27 Mar 2008 12:12:30 GMT
Connection: keep-alive
Accept-Ranges: bytes

[matej@localhost ~]$ 
Comment 11 Richard Hughes 2008-03-28 07:57:14 EDT
I've changed the mimetype of pk-install-file upstream to:

MimeType=application/x-rpm;application/x-redhat-package-manager;

This should fix things. They'll be a release today and should be in rawhide by
tomorrow.

Note You need to log in before you can comment on or make changes to this bug.