Bug 438260 - Something wrong with Pango support
Something wrong with Pango support
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 17:44 EDT by Havoc Pennington
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-21 15:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2008-03-19 17:44:07 EDT
For me, on a pretty fast x86_64 system, firefox-2.0.0.12-1.fc8 is pretty much
unusable by default in Fedora 8. Setting MOZ_DISABLE_PANGO=1 fixes it.

I don't mean "it's kind of slow", I mean loading even basic pages seems to take
many seconds and spin up my CPU fan, and switching to a workspace with Firefox
open will take a few seconds to repaint. While if I disable Pango, it repaints
instantly. Basically with Pango enabled it seems to be 1000% or so slower, not
say 50% slower. We're talking order of magnitude.

If this is something everyone is experiencing (how could it be my setup?), I
think it's something of a showstopper bug.
Comment 1 Ray Strode [halfline] 2008-03-19 17:46:50 EDT
Adding Behdad, since I think he wrote/fixed the pango integration.
Comment 2 Havoc Pennington 2008-03-19 17:50:56 EDT
Owen rightly points out that the first choice is to figure out what's wrong with
the pango support ... 
Comment 3 Behdad Esfahbod 2008-03-21 06:29:53 EDT
Well, I imagine not everyone has this problem, or we've had got hundreds of
reports.  I also have a hard time imagining how it could be a x86_64 issue... 
It works fine on my x86 F8.

How about a root-run fc-cache -f?  Only thing I can suspect is freetype
rescanning all fonts every time.  But have no plausible explanation for that either.
Comment 4 Matěj Cepl 2008-03-21 11:38:47 EDT
Havoc, I trust you understand that this bug is not even close to be perfectly
reported yet -- how can I reproduce it? I am working with Firefox all day every
day and I just cannot reproduce many-seconds loading of loading even basic
pages. Please, try harder to get some more about your environment, so that we
can reproduce it here -- your description is so general that (unless we overlook
couple of thousands reports per second about this, Behdad is right in this)
there is no way for me to reproduce it.

Anything interesting about your environment, something strange about your
network connection, using proxy?, any plugins (could you reproduce this with
firefox -safe-mode?), is it absolutely every page in the world (let's say
http://www.google.com, http://www.w3.org) or there is something unique about the
pages which are affected by this?

Thanks a lot for any response.

Matěj
Comment 5 Havoc Pennington 2008-03-21 15:38:09 EDT
Hi guys, I did go on IRC first and ask "is this just me?" and all I got was a
suggestion to file it - so, if it's not just me, I _did_ ask before filing ;-)

That said, I can't reproduce it anymore; I did a yum update at one point, it's
possible that fixed the font cache or something of that nature. I will let you
know if it happens again.

Note You need to log in before you can comment on or make changes to this bug.