Bug 438273 - kernel 2.6.24.3-34, no wireless with iwl3945
Summary: kernel 2.6.24.3-34, no wireless with iwl3945
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 8
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-20 00:45 UTC by Marc Dionne
Modified: 2008-04-04 20:24 UTC (History)
2 users (show)

Fixed In Version: 2.6.24.3-50.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 17:15:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg output (28.27 KB, text/plain)
2008-03-20 00:45 UTC, Marc Dionne
no flags Details
linux-2.6-iwlwifi-sband-registration.patch (2.01 KB, patch)
2008-03-20 14:24 UTC, John W. Linville
no flags Details | Diff
dmesg output with 2.6.24.3-50 (29.11 KB, text/plain)
2008-03-21 20:50 UTC, Milos Jakubicek
no flags Details
output of dmesg (179.18 KB, text/plain)
2008-03-27 17:19 UTC, jann
no flags Details

Description Marc Dionne 2008-03-20 00:45:13 UTC
Description of problem:

Wireless non-functional on laptop with iwl3945

Version-Release number of selected component (if applicable):

2.6.24.3-34.fc8

How reproducible:

Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

No wireless network.

Expected results:


Additional info:

See attached dmesg output.  The device fails to register, with a kernel warning:
WARNING: at net/wireless/core.c:249 wiphy_register() (Not tainted).
Wireless was also non-functional with previous kernel.

Comment 1 Marc Dionne 2008-03-20 00:45:13 UTC
Created attachment 298613 [details]
Dmesg output

Comment 2 John W. Linville 2008-03-20 14:24:39 UTC
Created attachment 298699 [details]
linux-2.6-iwlwifi-sband-registration.patch

Comment 3 John W. Linville 2008-03-20 18:14:44 UTC
This should be available in 2.6.24.3-50.fc8 (and probably thereafter):

   http://koji.fedoraproject.org/koji/taskinfo?taskID=523830

Give that a try and report the results here?  Thanks!

Comment 4 Marc Dionne 2008-03-20 20:51:32 UTC
Tried out i586 since it looked like i686 wasn't done building, and it's working
fine.

Thanks for the quick fix.

Comment 5 Fedora Update System 2008-03-21 03:15:11 UTC
kernel-2.6.24.3-50.fc8 has been submitted as an update for Fedora 8

Comment 6 Milos Jakubicek 2008-03-21 20:49:34 UTC
Unfortunately, 2.6.24.3-50 doesn't work too, but obviously for another reasons,
the association is just timed out (I'll attach my dmesg output). When I try to
setup the connection manually (i.e. I stop the NM and type "ifup wlan0"), I get:

Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; No such file or directory.

I didn't touch anything manually, except that after an upgrade to 2.6.24.3-34 I
renamed wlan0_rename back to wlan0 (under /etc/sysconfig/...).

The last working (concerning wireless) kernel for me is still 2.6.23.15-137.

Comment 7 Milos Jakubicek 2008-03-21 20:50:49 UTC
Created attachment 298808 [details]
dmesg output with 2.6.24.3-50

Comment 8 Fedora Update System 2008-03-21 22:16:27 UTC
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2630

Comment 9 John W. Linville 2008-03-24 15:15:18 UTC
Milos, whatever problem you are seeing is something completely different.  
Feel free to open a new bug for that issue, but please do not use this 
one...thanks!

Comment 10 Fedora Update System 2008-03-26 17:14:38 UTC
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 jann 2008-03-27 17:19:12 UTC
Created attachment 299363 [details]
output of dmesg

Comment 12 jann 2008-03-27 17:21:57 UTC
My English is not so good but I try to explain my problem

the last time my wireless card (iwl3945) worked was with the kernel 2.6.24.3-12.fc8

since kernel 2.6.24.3-34.fc8 I get maybe after hours of testing a connection

and my /var/log/messages  was  1,1GB big so I deleted it and doesn't  used my
intern wlan card

instead I used my external wlan card (rtl8187) but not with the driver which
comes with the kernel because this driver doesn't support ad-hoc mode, i used
the driver from this howto:
http://trac.aircrack-ng.org/ticket/378

now all was ok

after kernel update to  2.6.24.3-50.fc8
 I tested my intern wlan card again and it is all the same like with the 
2.6.24.3-34.fc8 kernel
at the moment my /var/log/messages is 178,8 MB big but at the time I don't used
my iwl3945 card it was always less than 1MB

I added  the output of dmesg there is written the same which makes my
/var/log/messages so big
on the last lines you can see that the other wlan card works
(https://bugzilla.redhat.com/attachment.cgi?id=299363)

i have my terminal set to 4000 lines that's why you can't see the beginning of dmesg

I want to use my intern wlan card again because our other computer has no wlan

please fix this bug

Comment 13 John W. Linville 2008-03-27 17:29:31 UTC
Jann, that is a different issue as well.  Please open a new bug for 
it...thanks!

Comment 14 Vitaly Mayatskikh 2008-04-04 20:24:27 UTC
The last working kernel for iwl3945 is 2.6.24.3-12. I have the same problems
with 2.6.24.3-64 (I'm using ad-hoc mode if it matters)


Note You need to log in before you can comment on or make changes to this bug.