Bug 438278 - Install MediaWiki Glossary Extension . . .
Install MediaWiki Glossary Extension . . .
Status: CLOSED NOTABUG
Product: Dogtag Certificate System
Classification: Community
Component: Wiki (Show other bugs)
1.0
All Linux
low Severity low
: 1.0
: ---
Assigned To: Benjamin Kahn
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2008-03-19 22:32 EDT by Matthew Harmsen
Modified: 2015-01-04 18:31 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 09:28:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Harmsen 2008-03-19 22:32:36 EDT
Benjamin Kahn sent the following email:

I wrote a mediawiki extension called Glossary located here:

http://www.mediawiki.org/wiki/Extension:Glossary

(since rewritten by "BarkerJr") to allow in-place tooltip definitions of
acronyms.

I believe it would make the CS wiki easier to digest.
Comment 1 Matthew Harmsen 2008-03-25 20:58:35 EDT
I have followed the instructions listed above, including installing 
/var/www/html/wiki/extensions/tooltip/tooltip_e.htm. When I place the line
require_once( "$IP/extensions/glossary.php" );, it blanks out the entire Dogtag
Wiki.

The page "http://pki.fedoraproject.org/wiki/Glossary" can be examined, but there
appears to be problems with this extension, or more than likely, with my
configuration of this extension.

I have everything in place, simply commented out in
/var/www/html/wiki/LocalSettings.php.
Comment 2 Benjamin Kahn 2008-03-25 22:08:20 EDT
Hmm...  I tested it on my local mediawiki install with no problems.   Do you
have access to the error_log?  What version of mediawiki is it?  I can try and
reproduce.
Comment 3 Rob Crittenden 2008-03-25 22:32:54 EDT
The error is:

[client 24.35.55.158] PHP Fatal error:  Cannot instantiate non-existent class: 
domdocument in /var/www/html/wiki/extensions/glossary.php on line 50, referer:
http://pki.fedoraproject.org/wiki/ECC_Enabling_Dogtag

The problem seems to be that this was written for PHP 5 and the wiki runs RHEL 4
so we have PHP 4.
Comment 4 Benjamin Kahn 2008-03-25 23:18:08 EDT
Oh yes.  The new version of this extension requires PHP5.  Let me see what I can
do to support PHP.
Comment 5 Benjamin Kahn 2008-04-04 22:15:31 EDT
Ahh... Support PHP4.
Comment 6 Bob Lord 2008-04-11 14:13:16 EDT
Assigning to Ben to work on backporting to PHP4.
Comment 7 Benjamin Kahn 2008-04-11 16:42:26 EDT
So I can port it, but any chance we can install php5 and a more recent version
of mediawiki?  PHP5 /is/ available for RHEL 4.
Comment 8 Matthew Harmsen 2008-04-11 17:21:54 EDT
I discussed this with Rob, and this seems risky from the standpoint that it is a
big change which would only be necessary to support this glossary plug-in.  We
would certainly prefer it to be ported to work with PHP4.
Comment 9 Benjamin Kahn 2008-04-14 14:47:12 EDT
Okay.  I've updated the URL http://www.mediawiki.org/wiki/Extension:Glossary
with a PHP 4 version (as well as the PHP 5 version)

I've done simple testing, and it seems to work well.
Comment 10 Benjamin Kahn 2008-07-10 13:21:04 EDT
My extension was moved to: http://www.mediawiki.org/wiki/Extension:Terminology

because I lost control of the previous URL.  :-/
Comment 11 Chandrasekar Kannan 2008-08-26 20:26:53 EDT
Bug already MODIFIED. setting target CS8.0 and marking screened+

Note You need to log in before you can comment on or make changes to this bug.