Bug 438283 - more than one version of packages installed
more than one version of packages installed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-19 23:41 EDT by Austin
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 02:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample yum output showing more than one version of a package installed. (305 bytes, text/plain)
2008-03-19 23:41 EDT, Austin
no flags Details
Another package with more than one version installed. (606 bytes, text/plain)
2008-03-19 23:49 EDT, Austin
no flags Details

  None (edit)
Description Austin 2008-03-19 23:41:17 EDT
Description of problem:
There is more than one version of some packages installed. This causes problems
with yum performing an update, as dependencies are "broken" when it doesn't work
for the existing (older) package. 

Version-Release number of selected component (if applicable):
# yum --version
3.2.12

How reproducible:
Quite frequent on this Fedora 9 pre-release. This occurs with some packages and
is only noticeable when yum can't "just perform an update". Individual packages
need to be selected, and even then I'm left with 50-60 packages that can't be
updated.

Steps to Reproduce:
1. Uncertain. It's just something that has happened from the installation of the
alpha x64 release, and yum doing updates since a month ago. I've not been able
to perform a complete update since then.
2.
3.
  
Actual results:
More than once version of a package is installed, preventing an update.

Expected results:
When an update is performed, for the old version to be removed so it's no longer
a problem.

Additional info:
Sample versioning problem attached. Can attach more yum-related output if it's
helpful.
Comment 1 Austin 2008-03-19 23:41:17 EDT
Created attachment 298623 [details]
Sample yum output showing more than one version of a package installed.
Comment 2 Austin 2008-03-19 23:49:42 EDT
Created attachment 298624 [details]
Another package with more than one version installed.

I found another package with more than one version installed, preventing it
from being updated.
Comment 3 seth vidal 2008-03-20 02:05:34 EDT
In most of these cases there was some sort of unpacking or scriptlet error
during the transaction which failed to let the package complete the 'cleanup'
portion of the update.

That happens more than is good in rawhide.

b/c the other package is installed you can fix this by running:
rpm -e pkgname-ver-rel.arch that you wish to remove.

But there's not much here to fix in yum.

Comment 4 Austin 2008-03-20 02:19:57 EDT
I have 42 cases of it in Rawhide at the moment that I've still to fix. Are you
suggesting that it's a problem with each of those packages instead of yum / rpm?
Comment 5 seth vidal 2008-03-20 02:24:36 EDT
yes.
Comment 6 Austin 2008-03-20 02:41:00 EDT
Are you also suggesting that I file bugs under the respective packages, instead
of yum?
Comment 7 Panu Matilainen 2008-03-20 04:28:10 EDT
It doesn't even have to be bugs in the individual packages - all it takes is a
slight selinux-mixup to have all scriptlets failing, leading to a mass
dupe-attack such as this. Impossible to say anything without seeing the original
transaction log which left the dupes around.

I'm going to make rpm ignore error exits on scriptlets other than %pre in
upstream but that wont help here...
Comment 8 Austin 2008-03-20 04:58:53 EDT
Even with SE-Linux set to permissive? Or are you just indicating that it's a
fragile system, and that it could be ANYthing...?

Note You need to log in before you can comment on or make changes to this bug.