Bug 438284 - Sometimes, pulseaudio failes to start.
Sometimes, pulseaudio failes to start.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
: 448477 (view as bug list)
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-03-20 00:44 EDT by sangu
Modified: 2009-06-27 11:45 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 02:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-03-20 00:44:09 EDT
Description of problem:
in /var/log/messages
[...]
Mar 20 07:50:19 localhost gdm-simple-slave[2274]: DEBUG: GdmSimpleSlave: session
started 2451
Mar 20 07:50:21 localhost seahorse-agent[2479]: Failed to send buffer
Mar 20 07:50:21 localhost seahorse-agent[2479]: Failed to send buffer
Mar 20 07:50:28 localhost pulseaudio[2671]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
Mar 20 07:50:28 localhost pulseaudio[2671]: main.c: We are not in group
'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Mar 20 07:50:28 localhost pulseaudio[2671]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
Mar 20 07:50:28 localhost pulseaudio[2671]: pid.c: Daemon already running.
Mar 20 07:50:28 localhost pulseaudio[2671]: main.c: pa_pid_file_create() failed.
[...]
$ ps ax | grep pulse
pulseaudio process doesn't be found.

$ rm /tmp/pulse-$userid/*
pulseaudio -D works well.

Version-Release number of selected component (if applicable):
0.9.8-12.fc9

How reproducible:
sometimes


Steps to Reproduce:
1. boot fedora linux box
2. login
3.  ps ax | grep pulseaudio
  
Actual results:


Expected results:


Additional info:
Comment 1 Lubomir Kundrak 2008-03-20 03:11:30 EDT
This should already been fixed in 0.9.8-12.fc9.
Should this happen again, please do the following:

$ cat /tmp/pulse-$LOGNAME/pid 
...
$ ps aux |grep $(cat /tmp/pulse-$LOGNAME/pid)
...
$

And paste the output.

Thanks!
Comment 2 Lennart Poettering 2008-03-28 15:37:20 EDT
This issue is fixed upstream and in 0.9.8-12.fc9. Closing bug.
Comment 3 sangu 2008-03-29 20:25:06 EDT
This problem Still happens in pulseaudio-0.9.8-13.fc9.i386, sometimes.
in /var/log/messages
Mar 30 08:23:04 localhost pulseaudio[2645]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
Mar 30 08:23:04 localhost pulseaudio[2645]: main.c: We are not in group
'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Mar 30 08:23:04 localhost pulseaudio[2645]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
Mar 30 08:23:04 localhost pulseaudio[2645]: pid.c: Daemon already running.
Mar 30 08:23:04 localhost pulseaudio[2645]: main.c: pa_pid_file_create() failed.

$ cat /tmp/pulse-$LOGNAME/pid 
2646
$ ps aux |grep $(cat /tmp/pulse-$LOGNAME/pid)
sangu     4806  0.0  0.0   4236   792 pts/2    R+   09:22   0:00 grep 2646

Comment 4 Gian Paolo Mureddu 2008-04-01 14:12:15 EDT
Will this be backported to F8? Pulseaudio in Fedora 8 is nearly of no use
whatsoever, as it works some times, and most of the time it does not. With
identical messages being printed to syslog (/var/log/messages)
Comment 5 Stefan Becker 2008-04-20 05:46:09 EDT
I can confirm that the problem still exists with

   pulseaudio-0.9.10-1.fc9.i386

One solution (at least for KDE) would be to add one line to
/etc/kde/env/pulseaudio.sh:

   if [ -x /usr/bin/pulseaudio ]; then
+    rm -rf /tmp/pulse-$LOGNAME
     /usr/bin/pulseaudio -D
   fi
Comment 6 Mikel Ward 2008-04-22 00:17:04 EDT
Still happening.

It exhibits itself when I try to change the volume from the command line.

$ amixer set Master 10%-
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
amixer: Mixer attach default error: Connection refused

$ ll /tmp/pulse-mward 
total 4
srwxrwxrwx 1 mward mward 0 2008-04-21 09:59 native
-rw------- 1 mward mward 5 2008-04-21 09:59 pid
$ date
Tue Apr 22 14:11:04 EST 2008

My computer was only started a few hours ago, so there's no way this can still
be running.

I'm running XFCE via the default XFCE session.  I have "PulseAudio Session
Management (Load module-x11-xsmp into PulseAudio)" configured as an autostarted
application.  There are no other PulseAudio entries in the list.
Comment 7 Bug Zapper 2008-05-14 02:45:19 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Martin Jürgens 2008-05-20 07:20:30 EDT
PulseAudio never starts automatically for me, but I do not know why. new users
that I create have pulseaudio running, but I also have to run pulseaudio -D
which is frustrating. Here's the /var/log/messages cutting:


May 20 13:16:04 medora pulseaudio[2738]: polkit.c: Cannot set UID on session object.
May 20 13:16:04 medora pulseaudio[2738]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
May 20 13:16:04 medora pulseaudio[2738]: main.c: We are not in group 'pulse-rt'
and PolicyKit refuse to grant us priviliges. Dropping SUID again.
May 20 13:16:04 medora pulseaudio[2738]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
May 20 13:16:04 medora pulseaudio[2738]: main.c: setrlimit(RLIMIT_NICE, (31,
31)) failed: Die Operation ist nicht erlaubt
May 20 13:16:04 medora pulseaudio[2738]: main.c: setrlimit(RLIMIT_RTPRIO, (9,
9)) failed: Die Operation ist nicht erlaubt
Comment 10 Dan O'Brien 2008-05-31 17:07:26 EDT
Just full installed F9 on a new Acer Intel box.

When I login, I see this in the messages log:

May 31 16:51:29 localhost pulseaudio[13892]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
May 31 16:51:29 localhost pulseaudio[13892]: main.c: We are not in group
'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
May 31 16:51:29 localhost pulseaudio[13892]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
May 31 16:51:29 localhost pulseaudio[13892]: pid.c: Stale PID file, overwriting.
May 31 16:51:29 localhost pulseaudio[13892]: main.c: setrlimit(RLIMIT_NICE, (31,
31)) failed: Operation not permitted
May 31 16:51:29 localhost pulseaudio[13892]: main.c: setrlimit(RLIMIT_RTPRIO,
(9, 9)) failed: Operation not permitted
May 31 16:51:30 localhost gconfd (dmobrien-13825): Resolved address
"xml:readwrite:/home/dmobrien/.gconf" to a writable configuration source at
position 0
May 31 16:51:30 localhost pulseaudio[13892]: module-x11-xsmp.c: X11 session
manager not running.
May 31 16:51:30 localhost pulseaudio[13892]: module.c: Failed to load  module
"module-x11-xsmp" (argument: ""): initialization failed.
Comment 11 Rui Matos 2008-06-30 12:56:13 EDT
This in indeed still happening on Fedora 9 with version

pulseaudio-0.9.10-1.fc9.x86_64

/var/log/messages say:
[ snip SUID stuff ]
Jun 30 13:53:04 hive pulseaudio[2482]: pid.c: Daemon already running.
Jun 30 13:53:04 hive pulseaudio[2482]: main.c: pa_pid_file_create() failed.

It happens randomly in around 10% of the logins I do. Still I don't think it has
to do with the /tmp/pulse-$LOGNAME dir contents since from a terminal I can run
it just fine like:

$ /usr/bin/pulseaudio --log-target=syslog
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

And then it logs on /var/log/messages:
[ snip SUID stuff ]
Jun 30 17:45:38 hive pulseaudio[4475]: pid.c: Stale PID file, overwriting.
[ snip setrlimit stuff ]
Comment 12 Rui Matos 2008-06-30 13:07:29 EDT
Should probably be marked as a dup of #444684.
Comment 13 Igor Pires Soares 2008-07-12 13:20:07 EDT
Same thing here:

/var/log/messages:

Jul 12 14:07:11 amd5600 pulseaudio[2496]: polkit.c: Cannot set UID on session
object.
Jul 12 14:07:11 amd5600 pulseaudio[2496]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
Jul 12 14:07:11 amd5600 pulseaudio[2496]: main.c: We are not in group 'pulse-rt'
and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Jul 12 14:07:11 amd5600 pulseaudio[2496]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
Jul 12 14:07:11 amd5600 pulseaudio[2496]: main.c: setrlimit(RLIMIT_NICE, (31,
31)) failed: Operação não permitida (Operation not permitted)
Jul 12 14:07:11 amd5600 pulseaudio[2496]: main.c: setrlimit(RLIMIT_RTPRIO, (9,
9)) failed: Operação não permitida (Operation not permitted)
Jul 12 14:07:11 amd5600 pulseaudio[2496]: alsa-util.c: Device hw:1 doesn't
support 44100 Hz, changed to 32000 Hz.

.
.
.

Jul 12 14:07:40 amd5600 pulseaudio[2615]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
Jul 12 14:07:40 amd5600 pulseaudio[2615]: main.c: We are not in group 'pulse-rt'
and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Jul 12 14:07:40 amd5600 pulseaudio[2615]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
Jul 12 14:07:40 amd5600 pulseaudio[2615]: pid.c: Daemon already running.
Jul 12 14:07:40 amd5600 pulseaudio[2615]: main.c: pa_pid_file_create() failed.
Comment 14 Martin Jürgens 2008-07-12 14:41:56 EDT
you can try to set the gconf value of /desktop/gnome/sound/enable_esd to true. 
Comment 15 Igor Pires Soares 2008-07-12 15:15:45 EDT
It is already enabled
Comment 16 Mikel Ward 2008-07-24 05:15:04 EDT
Happened again and nearly blew my ears off.  I had my headphones on to watch a
movie clip and it came on at full volume, which was really, really loud.
(perhaps the appropriate mixer levels weren't restored via
/etc/alsa/asound.state or wherever).

My asound set Master 10%- keyboard binding (Win+down) didn't work, so I had to
pull my earphones out.

Very annoying!  Do you guys understand what the cause is?  How can I help fix it?

Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_intel.c:1810: chipset
global capabilities = 0x4401
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_intel.c:749: codec_mask = 0x3
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:2236: hda_codec:
model 'dell-m43' is selected for config 1028:1f9 (Dell Precision)
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 0a pin config 0321101f
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 0b pin config 03a11020
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 0c pin config 90a70330
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 0d pin config 90170310
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 0e pin config 400000fe
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 0f pin config 400000ff
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 14 pin config 400000fd
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 16 pin config 40f000f9
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 17 pin config 400000fa
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 18 pin config 400000fc
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 21 pin config 0144131f
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 22 pin config 40c003f8
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 1f pin config 00000000
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:1712:
hda_codec: pin nid 20 pin config 00000000
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/patch_sigmatel.c:2080:
stac92xx_add_dyn_out_pins: total dac count=2
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Surround Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Center Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave LFE Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Side Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Headphone Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Headphone Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Speaker Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave External Speaker Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Speaker2 Playback Volume, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Surround Playback Switch, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Center Playback Switch, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave LFE Playback Switch, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Side Playback Switch, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Headphone Playback Switch, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Headphone Playback Switch, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Speaker Playback Switch, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave External Speaker Playback Switch, skipped
Jul 24 09:38:03 laptop kernel: ALSA sound/pci/hda/hda_codec.c:1073: Cannot find
slave Speaker2 Playback Switch, skipped
Jul 24 09:38:29 laptop pulseaudio[2642]: polkit.c: Cannot set UID on session object.
Jul 24 09:38:29 laptop pulseaudio[2642]: main.c: Called SUID root and
real-time/high-priority scheduling was requested in the configuration. However,
we lack the necessary priviliges:
Jul 24 09:38:29 laptop pulseaudio[2642]: main.c: We are not in group 'pulse-rt'
and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Jul 24 09:38:29 laptop pulseaudio[2642]: main.c: For enabling real-time
scheduling please acquire the appropriate PolicyKit priviliges, or become a
member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits
for this user.
Jul 24 09:38:29 laptop pulseaudio[2642]: main.c: setrlimit(RLIMIT_NICE, (31,
31)) failed: Operation not permitted
Jul 24 09:38:29 laptop pulseaudio[2642]: main.c: setrlimit(RLIMIT_RTPRIO, (9,
9)) failed: Operation not permitted
Jul 24 09:38:43 laptop pulseaudio[2885]: pid.c: Daemon already running.
Jul 24 09:38:43 laptop pulseaudio[2885]: main.c: pa_pid_file_create() failed.
Comment 17 Andre Robatino 2008-09-03 13:02:04 EDT
It might be a timing issue.  On my 2.5 GHz F9 box, pulseaudio fails to start only about 5-10% of the time.  On my father's 1.1 GHz F9 box, it's more like half to two-thirds of the time.  It's a major pain to have to check for the process after each login.
Comment 18 Andre Robatino 2008-09-04 07:55:50 EDT
(In reply to comment #12)
> Should probably be marked as a dup of #444684.

I don't think bug #444684 (failure to clean up /tmp/pulse-$USER/* during logout) is actually a bug, since pulseaudio, or any other service, needs to be able to start up correctly regardless of whether things were cleaned up before - cleanup is not always possible, for example during an unclean shutdown.  Someone said there that the latest PA handles startup correctly (unlike the present F9 version), and if that's true, that version needs to be pushed in order to fix this.
Comment 19 Fedora Update System 2008-09-10 14:38:04 EDT
pulseaudio-0.9.10-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/pulseaudio-0.9.10-2.fc9
Comment 20 Fedora Update System 2008-09-11 12:58:04 EDT
pulseaudio-0.9.10-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pulseaudio'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7814
Comment 21 Fedora Update System 2008-10-01 02:37:40 EDT
pulseaudio-0.9.10-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Kevin Kofler 2008-10-05 19:30:24 EDT
*** Bug 448477 has been marked as a duplicate of this bug. ***
Comment 23 Kevin Kofler 2008-10-05 19:36:05 EDT
Could you please also push the same fix you pushed to F9 to F8 too? Or is it hard to backport to the old PA in F8?

Fixing session management support for PA in KDE isn't really possible for F8 (it's only possible for F10 and later thanks to the reworked PA start logic, and in fact it should be already fixed there with the current Rawhide versions of pulseaudio and kde-settings), so the extra validation of the pidfile is the only way to stop this annoyance on F8. (And yes, it definitely also affects F8, I've seen it happening on my own machine.)

Note You need to log in before you can comment on or make changes to this bug.