Bug 438294 - rebooting DomU fails after numberous reboots
rebooting DomU fails after numberous reboots
Status: CLOSED DUPLICATE of bug 435356
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 05:12 EDT by David Robinson
Modified: 2009-12-14 16:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 08:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Robinson 2008-03-20 05:12:27 EDT
Description of problem:

Rebooting a Xen guest doesn't always work. After rebooting the guest a random
number of times rebooting stops working and the error message below appears in
/var/log/xen/xend.log.

------------------------------------------------------
[2008-03-14 13:44:17 xend.XendDomainInfo 5491] DEBUG (XendDomainInfo:1559)
XendDomainInfo.destroy: domid=2
[2008-03-14 13:44:17 xend.XendDomainInfo 5491] DEBUG (XendDomainInfo:1567)
XendDomainInfo.destroyDomain(2)
[2008-03-14 13:44:17 xend.XendDomainInfo 5491] ERROR (XendDomainInfo:1863)
Failed to restart domain 1.
Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 1849,
in restart
  new_dom.waitForDevices()
File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 1762,
in waitForDevices
  self.waitForDevices_(c)
File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 1158,
in waitForDevices_
  return self.getDeviceController(deviceClass).waitForDevices()
File "/usr/lib/python2.4/site-packages/xen/xend/server/DevController.py", line
145, in waitForDevices
  return map(self.waitForDevice, self.deviceIDs())
File "/usr/lib/python2.4/site-packages/xen/xend/server/DevController.py", line
155, in waitForDevice
  raise VmError("Device %s (%s) could not be connected. "
VmError: Device 0 (vif) could not be connected. Hotplug scripts not working.
[2008-03-14 13:44:18 xend 5491] DEBUG (DevController:476) hotplugStatusCallback
/local/domain/0/backend/vif/2/0/hotplug-status.
[2008-03-14 13:44:18 xend 5491] DEBUG (DevController:490) hotplugStatusCallback 1.
-----------------------------------------------------

Once the problem has occurred it will continue occurring until the host is
rebooted. Our customer rebooted a guest 372 times before the problem occured,
however the number of reboots required varies. The guest appears to shutdown
correctly, but cannot be started. The problem doesn't occur on RHEL 5.1. The
problem occurs with both PV and FV guests, and on IA64 and x86 architectures
(x86_64 hasn't been confirmed).

Version-Release number of selected component (if applicable):
RHEL 5.2 beta

How reproducible:
100%

Step to Reproduce:
# xm reboot
or 'reboot' from within the guest

Actual Results:
Eventually the guest will shutdown and won't be able to restart.

Expected Results:
Guest always reboots correctly.

Additional info:
Comment 2 Daniel Berrange 2008-03-20 08:11:47 EDT

*** This bug has been marked as a duplicate of 435356 ***

Note You need to log in before you can comment on or make changes to this bug.