This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 438299 - DDC fails on PowerBook
DDC fails on PowerBook
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9KernelBlocker
  Show dependency treegraph
 
Reported: 2008-03-20 05:39 EDT by David Woodhouse
Modified: 2008-04-18 02:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 02:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log from Fedora 8 (47.89 KB, text/plain)
2008-03-20 05:42 EDT, David Woodhouse
no flags Details
Xorg.log from Fedora 9 (34.96 KB, text/plain)
2008-03-20 05:43 EDT, David Woodhouse
no flags Details
Electra Xorg.log (37.70 KB, text/plain)
2008-03-20 08:04 EDT, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2008-03-20 05:39:28 EDT
Fedora 8 correctly reported the panel on my shinybook:
(II) RADEON(0): I2C device "DVI_DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): DDC Type: 2, Detected Monitor Type: 2
(II) RADEON(0): EDID data from the display on connector: Proprietary/LVDS
----------------------
(II) RADEON(0): Manufacturer: APP  Model: 9c2c  Serial#: 0
(II) RADEON(0): Year: 2003  Week: 1
(II) RADEON(0): EDID Version: 1.3
(II) RADEON(0): Digital Display Input
(II) RADEON(0): Max H-Image Size [cm]: horiz.: 37  vert.: 23
....

Fedora 9 (xorg-x11-drv-ati-6.8.0-3.fc9) doesn't:
(II) RADEON(0): Output: LVDS, Detected Monitor Type: 0
(II) RADEON(0): Detected non-DDC Monitor Type: 2
finished output detect: 0
Comment 1 David Woodhouse 2008-03-20 05:42:36 EDT
Created attachment 298672 [details]
Xorg.log from Fedora 8
Comment 2 David Woodhouse 2008-03-20 05:43:06 EDT
Created attachment 298673 [details]
Xorg.log from Fedora 9
Comment 3 David Woodhouse 2008-03-20 08:04:11 EDT
Created attachment 298688 [details]
Electra Xorg.log

I see DDC failure on an NV card too...
Comment 4 David Woodhouse 2008-03-20 21:10:32 EDT
The DDC failure on ATI goes away, along with the crash on my G5, when I change
RADEONGetBIOSInfo() to avoid allocating a buffer of 64KiB and then immediately
asking pci_device_read_rom() to read the 128KiB BIOS ROM into it.

Why is it that we don't allocate a buffer of size info->PciInfo->rom_size,
anyway? That seems to be commented out, and we allocate RADEON_VBIOS_SIZE
(64KiB) instead.
Comment 5 David Woodhouse 2008-03-20 21:23:46 EDT
--- a/src/radeon_bios.c
+++ b/src/radeon_bios.c
@@ -74,8 +74,8 @@ Bool RADEONGetBIOSInfo(ScrnInfoPtr pScrn, xf86Int10InfoPtr 
pInt10)
     unsigned short dptr;
 
 #ifdef XSERVER_LIBPCIACCESS
-    //info->VBIOS = xalloc(info->PciInfo->rom_size);
-    info->VBIOS = xalloc(RADEON_VBIOS_SIZE);
+    info->VBIOS = xalloc(info->PciInfo->rom_size);
+    //    info->VBIOS = xalloc(RADEON_VBIOS_SIZE);
 #else
     info->VBIOS = xalloc(RADEON_VBIOS_SIZE);
 #endif
Comment 6 Jon Stanley 2008-04-16 21:03:17 EDT
Has this made it into rawhide yet? (just reviewing the F9 blocker)
Comment 7 Dave Airlie 2008-04-18 02:02:05 EDT
should be fixed in rawhide this patch is in at least.

Note You need to log in before you can comment on or make changes to this bug.