This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 438322 - padlock_sha module dies when mounting CIFS share (gPC - everex tc2502 - via c7-d)
padlock_sha module dies when mounting CIFS share (gPC - everex tc2502 - via c...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kerneloops (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 07:53 EDT by James Boyle
Modified: 2011-12-13 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.24.5-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 16:54:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 10287 None None None Never

  None (edit)
Description James Boyle 2008-03-20 07:53:44 EDT
Description of problem:
CIFS/Samba mount fails, neither the mount or modprobe cifs completes
Appears to be related to padlock_sha

Version-Release number of selected component (if applicable):
kernel-2.6.24.3-34.fc8

How reproducible: Always

Steps to Reproduce:
1. sudo mount -t cifs -o username=user,uid=500,gid=500 //winxp/share /share
2. hit return, and receive the kernel message below:

  
Actual results:
mount does not complete, both mount and modprobe hang and are unkillable

Cut from ps auxww:
root      4467  0.0  0.1   1904   680 pts/0    D    20:50   0:00
/sbin/mount.cifs //winxp/share /share -o rw,username=user,uid=500,gid=500
root      4469  0.0  0.1   1812   452 ?        D    20:50   0:00 /sbin/modprobe
-q -- cifs

Expected results:
mount -t cifs should work.

Additional info:
Works just fine under 2.6.23.15-137.fc8,
also broken with 2.6.24.3-12.fc8

System is VIA C7, gPC, Everex TC2502, PCI eSATA card: sil 3114
(Addonics), x4 Seagate external sata HDDs in RAID5.

cat /proc/cpuinfo:
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 10
model name      : VIA Esther processor 1500MHz
stepping        : 9
cpu MHz         : 1500.011
cache size      : 128 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge cmov pat
clflush acpi mmx fxsr sse sse2 tm nx up pni rng rng_en ace ace_en ace2 ace2_en
phe phe_en pmm pmm_en
bogomips        : 3002.45
clflush size    : 64

------------[ cut here ]------------
kernel BUG at arch/x86/mm/highmem_32.c:70!
invalid opcode: 0000 [#1] SMP 
Modules linked in: padlock_sha sha256_generic geode_aes padlock_aes aes_i586
aes_generic cbc blkcipher dm_crypt ipt_MASQUERADE iptable_nat nf_nat bridge
autofs4 fuse sunrpc nf_conntrack_ipv4 ipt_REJECT iptable_filter ip_tables
nf_conntrack_ipv6 xt_state nf_conntrack xt_tcpudp ip6t_ipv6header ip6t_REJECT
ip6table_filter ip6_tables x_tables ipv6 ib_iser rdma_cm ib_cm iw_cm ib_sa
ib_mad ib_core ib_addr iscsi_tcp libiscsi scsi_transport_iscsi dm_multipath
raid456 async_xor async_memcpy async_tx xor snd_via82xx gameport snd_ac97_codec
ac97_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_pcm_oss
parport_pc parport snd_mixer_oss snd_pcm snd_timer 8139too snd_page_alloc
snd_mpu401_uart floppy snd_rawmidi serio_raw pcspkr i2c_viapro 8139cp
snd_seq_device snd i2c_core mii soundcore usb_storage button sg sr_mod cdrom
sata_via sata_sil dm_snapshot dm_zero dm_mirror dm_mod ata_generic pata_acpi
pata_via libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd

Pid: 4434, comm: modprobe Not tainted (2.6.24.3-34.fc8 #1)
EIP: 0060:[<c0423feb>] EFLAGS: 00010206 CPU: 0
EIP is at kunmap_atomic+0x77/0xad
EAX: fffb2000 EBX: dcd5c000 ECX: 00000000 EDX: 0004d000
ESI: 00000058 EDI: 00000007 EBP: dcd5c058 ESP: c5457d50
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process modprobe (pid: 4434, ti=c5457000 task=d23593b0 task.ti=c5457000)
Stack: 00000000 c0723d00 00000058 0001e8f4 dcd5c058 c04e6556 00000000 c5457db0 
       c3d51bf4 c3e1d780 00000003 c139ab80 00000fa8 dcd5c000 c3e1d780 00000058 
       c5457dc0 c3d51bc0 dccff212 c5457db0 c5457db0 0001e8f4 0000005b c3d51bf4 
Call Trace:
 [<c04e6556>] update2+0xf2/0x144
 [<dccff212>] padlock_sha_update+0x133/0x15e [padlock_sha]
 [<c04e6723>] update_kernel+0xf/0x1f
 [<c044e434>] module_verify_signature+0x4a8/0x564
 [<c04421bb>] hrtimer_interrupt+0x192/0x1bb
 [<c044d939>] module_verify+0x4d/0x6c
 [<c04334a0>] irq_exit+0x53/0x6b
 [<c044be04>] sys_init_module+0xd6/0x15f9
 [<c0488e3b>] do_sync_read+0xc7/0x10a
 [<c0484d05>] __slab_free+0x5e/0x204
 [<c043f0a1>] autoremove_wake_function+0x0/0x35
 [<c0478b2e>] do_munmap+0x193/0x1ac
 [<c045e06a>] audit_syscall_exit+0x2c7/0x2e3
 [<c045dd79>] audit_syscall_entry+0x10d/0x137
 [<c04080dc>] do_syscall_trace+0xd7/0xde
 [<c04051da>] syscall_call+0x7/0xb
 =======================
Code: 89 da 55 e8 34 e7 ff ff 90 8d 64 24 04 89 d8 e8 6b e1 ff ff 90 eb 18 81
fb ff ff ff bf 77 04 0f 0b eb fe 3b 1d 0c a7 83 c0 72 04 <0f> 0b eb fe e8 4f e1
ff ff 48 75 0c 8d b6 00 00 00 00 8d b6 00 
EIP: [<c0423feb>] kunmap_atomic+0x77/0xad SS:ESP 0068:c5457d50
---[ end trace 30fd7e378b630fff ]---

More info available upon request,
Thanks,
--James
Comment 1 Chuck Ebbert 2008-03-20 20:10:50 EDT
Try blacklisting the padlock_sha module by adding it to
/etc/modprobe.d/modules.blacklist
Comment 2 James Boyle 2008-03-20 21:53:09 EDT
Ok, I'll try that when I can and append with more info.
--J
Comment 3 James Boyle 2008-03-21 16:44:10 EDT
My machine appears to be behaving now with 2.6.24.3-34.fc8, even with
padlock_aes loaded. (padlock_sha is in the blacklist)

$ lsmod |egrep -i pad\|aes\|sha
sha256_generic         15041  0 
geode_aes               8777  0 
padlock_aes            26241  2 
aes_i586               36673  0 
aes_generic            31361  0 
blkcipher               9285  3 geode_aes,padlock_aes,cbc

`mount -t cifs` worked as expected.

--James

Comment 4 Chuck Ebbert 2008-03-26 16:30:29 EDT
I wonder if we should just stop building the padlock_sha module. (This problem
is caused by some interaction between that and the module-signature verification
code.)
Comment 5 Chuck Ebbert 2008-04-02 19:04:22 EDT
Disabled the padlock SHA driver in 2.6.24.4-71
Comment 6 Fedora Update System 2008-04-21 20:04:29 EDT
kernel-2.6.24.5-85.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-04-22 18:42:59 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3260
Comment 8 Fedora Update System 2008-04-29 16:54:19 EDT
kernel-2.6.24.5-85.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Jan Andrejkovic 2008-05-03 21:24:24 EDT
Please also check my bug - #295581. Problem is NOT in padlock-sha but there is a
conflict between module digital signing and padlock-sha module. Module digital
signing will be removed in F9 so padlock-sha will work fine.
PLEASE DO NOT REMOVE padlock-sha from F9 as well !!!

Note You need to log in before you can comment on or make changes to this bug.