Bug 438326 - kernel module p4-clockmod no longer available
kernel module p4-clockmod no longer available
Status: CLOSED DUPLICATE of bug 428895
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 08:12 EDT by Ronny Fischer
Modified: 2008-04-12 08:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 11:50:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Fischer 2008-03-20 08:12:37 EDT
Description of problem:
Since Kernel 2.6.24 the cpufrq module p4-clockmod isn't any longer included in
the kernel

cat /boot/config-2.6.23.15-80.fc7 | grep P4_CLOCKMOD

gives following information

# CONFIG_X86_P4_CLOCKMOD is not set

This is quite redicolous because there was no announcement that this module will
be disabled. Even so, I see no need to disable this and I guess that users of a
Pentium 4 won't be happy to let their CPU run at full speed all the time.

Version-Release number of selected component (if applicable):
Kernel 2.6.24, Fedora 8

How reproducible:
always

Steps to Reproduce:
1. run Fedora 8 with Kernel 2.6.24 and try to adjust the speed of a Pentium 4
2.
3.
  
Actual results:
P4 like processors run at full speed permanently, missing p4-clockmod produces
errors at the start of cpufreq and related software

Expected results:
cpufreq with p4-clockmod should clock a P4 processor autmatically

Additional info:

It would be nice for users of older Pentium 4 CPUs if the module p4-clockmod
will be included again.
Comment 1 Dave Jones 2008-03-20 11:50:33 EDT

*** This bug has been marked as a duplicate of 428895 ***
Comment 2 Ronny Fischer 2008-03-20 16:36:40 EDT
Excuse me for beeing a bit rude, but this isn't a solution for the underlying 
problem.

If the module itself has a problem, it should be fixed, not disabled. On the 
other hand it isn't really fair to do so just by the report of one reporter. 
There are at least two persons whih don't have these issues.

So you should try and fix the difficulties or at least try to get a workaround 
for this.

Ronny
Comment 3 Dave Jones 2008-03-20 16:49:33 EDT
it has no redeeming value, and it's not clear that the problem cases are fixable.
Comment 4 Ronny Fischer 2008-04-12 08:37:33 EDT
I made a fresh installation of Fedora 8 via DVD to see where the error lies.

I have the following results:

With the release kernel of Fedora 8 (2.6.23-1.42) p4-clockmod IS FULLY 
OPERATIONAL on a P4 with HT on.
That means I am able to use either ondemand, userspace or performance scaling 
of the CPU through cpuspeed. The lowest frequency can be 325MHz, the highest is 
at 2.6GHz. No errors occured during the test. I've tried to reproduce the case 
mentioned in this bug.

https://bugzilla.redhat.com/show_bug.cgi?id=428895

but everything works fine.

I would suggest to re-enable this module as quick as possible and to follow the 
suggestion to blacklist it only.

Thx

Ronny

Note You need to log in before you can comment on or make changes to this bug.