Bug 438327 - System hangs on shutdown or reboot
System hangs on shutdown or reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 08:30 EDT by Martin Kopp
Modified: 2008-07-30 10:12 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 10:12:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kopp 2008-03-20 08:30:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Description of problem:
The system hangs on a shutdown or reboot.
The problem was introduced with a new kernel. 
With kernel 2.6.23.15-137.fc8 everythink was OK.
After halting system, the system hangs. See log below



Version-Release number of selected component (if applicable):
kernel 2.6.24.3-34.fc8

How reproducible:
Always


Steps to Reproduce:
1. Shudown or Reboot
2.
3.

Actual Results:
System hangs.

Expected Results:
Reboot or Powerdown

Additional info:
Last screen: 
[<c0442b91>] __blocking_notifier_call_chain+0x3e/0x51
[<c0442b9b>] blocking_notifier_call_chain+0x17/0x25
[<c04399cd>] kernel_restart_prepare+0x11/0x25
[<c0439ae8>] kernel_restart+0xb/0x37
[<c062c253>] lock_kernel+0x23/0x3d
[<c0439c62>] sys_reboot+0x147/0x1ba
[<c0404210>] __switch_to+0xcb/0x147
[<c062ad1f>] schedule+0x624/0x663
[<c0441537>] enqueue_hrtimer+0xd1/0xdc
[<c0441ab3>] lock_hrtimer_base+0x15/0x2f
[<c0441b60>] hrtimer_try_to_cancel+0x5f/0x67
[<c0441b72>] hrtimer_cancel+0xa/0x14
[<c062b464>] do_nanosleep+0x4f/0x73
[<c0441cd0>] hrtimer_nanosleep+0x50/0xaf
[<c045e06a>] audit_syscall_exit+0x2c7/0x2e3
[<c045dd79>] audit_syscall_entry+0x10d/0x137
[<c04080dc>] do_syscall_trace+0xd7/0xde
[<c04051da>] syscall_call+0x7/0xb
=======================
Code: b7 c1 eb 03 0f b7 c0 66 85 c0 66 89 44 24 22 0f 84 3e 01 00 00 8b 6a 78 66
 c7 44 24 24 00 00 66 c7 44 24 26 00 00 e9 17 01 00 00 <8b> 45 0c 0f b7 54 24 26
 66 8b 4c 24 22 66 2b 4c 24 26 66 89 44
EIP: [<f08e5f49>] gdth_copy_internal_data+0x5a/0x1e0 [gdth] SS:ESP 0068:eef148d0
---[ end trace 7fa5744e9116fd7e ]---

System:

SCSI: 	GDT-PCI RAID Controller GDT6523RS (ICP) 6 x 9.1GB Raid-5
Proc:	AMD Sempron 3200+
Motherboard: Asus KBV-X
RAM:	DDR 768MB

On manual reboot the system is OK.

Note You need to log in before you can comment on or make changes to this bug.