Bug 438340 - lock files are badly handled by all init scripts
lock files are badly handled by all init scripts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iprutils (Show other bugs)
4.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Roman Rakus
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 09:49 EDT by Milos Malik
Modified: 2014-01-12 19:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0697
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:49:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-03-20 09:49:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
There are more mistakes in those init scripts:

1. Lock files are created in function start() but they are not removed in function stop().
2. The existence of a lock file is never tested, so daemons could be run multiple times.
3. /etc/init.d/<script> condrestart does nothing, because "[ -d $lockfile ]" tests the existence of a directory. But lock file is not a directory.

Version-Release number of selected component (if applicable):
iprutils-2.2.8-1

How reproducible:
Always


Steps to Reproduce:
1. look into /etc/init.d/iprdump
2. look into /etc/init.d/iprinit
3. look into /etc/init.d/iprupdate


Actual Results:


Expected Results:


Additional info:
Comment 1 RHEL Product and Program Management 2008-03-25 06:48:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 David Cantrell 2008-03-25 16:56:51 EDT
These are also relatively easy to clean up.  Giving it a devel-ack.
Comment 4 Roman Rakus 2008-03-28 07:27:16 EDT
Init scripts have been fixed in the iprutils-2.2.8-2.el4 build, which has been
tagged and built.  Moving bug to MODIFIED.
Comment 8 errata-xmlrpc 2008-07-24 15:49:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0697.html

Note You need to log in before you can comment on or make changes to this bug.