Bug 438361 - compositing manager breaks totem (Xv, presumably)
compositing manager breaks totem (Xv, presumably)
Status: CLOSED DUPLICATE of bug 239125
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 11:32 EDT by Bill Nottingham
Modified: 2014-06-18 05:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 01:29:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X log (29.39 KB, text/plain)
2008-04-03 17:33 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2008-03-20 11:32:42 EDT
Description of problem:

If the CM is active, any time totem wants to display a video/visualization, it
receives:

The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 783 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Turning off the CM 'fixes' it. Filing initially against metacity, I suppose this
bug could be in anywhere from the intel driver up to the gstreamer stack.

Version-Release number of selected component (if applicable):

totem-2.23.0-5.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-10.20080314.fc9.x86_64
xorg-x11-drv-i810-2.2.1-14.fc9.x86_64
metacity-2.22.0-2.fc9.x86_64
gstreamer-0.10.17.2-1.fc9.x86_64

How reproducible:

Every time
Comment 1 Thorsten Leemhuis 2008-03-28 13:08:49 EDT
Confirmed. The error I got as soon Metacity's CM is enabled is:
----
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 59 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
----
Hardware: GM965 with xorg-x11-drv-i810-2.2.1-15.fc9.x86_64 (and rawhide up2date
as of 20080328)

/me wonders if we should CC xgl-maint@redhat.com, as it might be a bug/feature
of the driver...
Comment 2 Sindre Pedersen Bjørdal 2008-04-02 09:44:44 EDT
I believe this is a bug in the driver. Using the intel driver, switching to EXA
instead of XAA works around this bug. I added the following to my
/etc/X11/xorg.conf Device section:

Option "AccelMethod" "EXA"

Now both Xv and compositing works. 

Comment 3 Thorsten Leemhuis 2008-04-03 11:25:22 EDT
(In reply to comment #2)
> I believe this is a bug in the driver.

CCing xgl-maint, to get their opinion if this is a bug in metacity or the intel
driver

> Using the intel driver, switching to EXA
> instead of XAA works around this bug. I added the following to my
> /etc/X11/xorg.conf Device section:
> Option "AccelMethod" "EXA"
> Now both Xv and compositing works. 
Comment 4 Matěj Cepl 2008-04-03 16:55:39 EDT
Can we get /var/log/Xorg.*.log please?
Comment 5 Bill Nottingham 2008-04-03 17:33:04 EDT
Created attachment 300348 [details]
X log

Here you go. Doesn't look like anything of value is in there.
Comment 6 Bill Nottingham 2008-04-08 01:29:32 EDT

*** This bug has been marked as a duplicate of 239125 ***

Note You need to log in before you can comment on or make changes to this bug.