Bug 438393 - Put repomd-precache.py in an rpm that can be installed on the xmlservers
Summary: Put repomd-precache.py in an rpm that can be installed on the xmlservers
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend   
(Show other bugs)
Version: rhn500
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bryan Kearney
QA Contact: Amy Owens
URL:
Whiteboard: US=19857
Keywords:
Depends On:
Blocks: 436329
TreeView+ depends on / blocked
 
Reported: 2008-03-20 18:32 UTC by James Bowes
Modified: 2013-01-10 09:58 UTC (History)
2 users (show)

Fixed In Version: 5.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 20:22:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Bowes 2008-03-20 18:32:23 UTC
the code lives under scripts, but scripts installs some cron jobs

Comment 1 James Bowes 2008-03-25 12:16:10 UTC
repomd-precache is used by SOC to refresh the rhel5 and up repository metadata
after an environment refresh or after releasing a new rhel revision.

Because the data it creates is accessed by clients, the program must be on
xmlserver class machines.

Right now the code is under the rhns-scripts rpm dir, but we can't install those
rpms on xmlservers, because the rpms set up some cron jobs we wouldn't want
running there.

Comment 2 James Bowes 2008-03-28 15:32:10 UTC
it's now included in rhnh-python-xmlrpc and installed in /usr/bin

Comment 3 Amy Owens 2008-03-28 16:29:28 UTC
On dev on rhnxml box--all set in dev
1722 Mar 27 18:20 repomd-precache

Comment 4 Amy Owens 2008-06-17 17:02:15 UTC
in qa:
-rwxr-xr-x  1 root root       1722 Jun  3 15:27 repomd-precache



Note You need to log in before you can comment on or make changes to this bug.