Bug 438435 - xcompmgr pixmap usage appears to grow without bound
xcompmgr pixmap usage appears to grow without bound
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xcompmgr (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 17:04 EDT by Daniel Berrange
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 13:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2008-03-20 17:04:48 EDT
Description of problem:
I'm running 

   xcompmgr -n -f -c -C

In my regular GNOME session. After a couple of hours of desktop usage xrestop
shows it has  650 MB of pixmaps allocated on the X server

res-base Wins  GCs Fnts Pxms Misc   Pxm mem  Other   Total   PID Identifier    
0600000     1    1    0  285 17763   649297K    416K 649713K   ?   xcompmgr

this appears to be continuing to go up consuming all my RAM pushing other apps
into Swap. It is unclear whether this is a 'leak' or just over aggressive
caching - if the latter it needs to purge things a bit more often.

If I kill xcompmgr all pixmaps are freed.



Version-Release number of selected component (if applicable):
xcompmgr-1.1.3-7.fc8
xorg-x11-server-Xorg-1.3.0.0-42.fc8

How reproducible:
Always

Steps to Reproduce:
1. Run xcompmgr -n -f -c -C
2. Use desktop for 2 hours
3.
  
Actual results:
X is using huge amounts of memory for pixmaps for xcompmgr client

Expected results:
A 'reasonable' amount of memory is used - where 'reasonable' < ALL RAM.

Additional info:
In case it is relevant, the machine has a r500 graphics card, and is using the
open source ATI driver from the  r3xx-render branch. 

It doesn't appear to be driver specific though, because another machine with
Nvidia driver is showing similar levels of pixmap / RAM usage.
Comment 1 Deji Akingunola 2008-03-20 17:23:36 EDT
Can you please test with the latest version of xcompmgr in updates-testing, and
report if it fix the issue for you? You can install it with
su -c 'yum --enablerepo=updates-testing update xcompmgr
Comment 2 Daniel Berrange 2008-05-09 13:40:21 EDT
Yes, this update fixed it, closing the bug.

Note You need to log in before you can comment on or make changes to this bug.