Bug 438438 - rtl8180 keeps timing out
rtl8180 keeps timing out
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 17:18 EDT by Andrew Pegram
Modified: 2009-03-17 13:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 13:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages exerpt (13.71 KB, text/plain)
2008-03-24 14:08 EDT, Andrew Pegram
no flags Details
First output is while it was disconnected, Second is while connected (11.40 KB, text/plain)
2008-03-24 15:23 EDT, Andrew Pegram
no flags Details
0002-rtl8180-normalize-quality-measurment-for-100-point.patch (1.11 KB, patch)
2008-10-07 15:30 EDT, John W. Linville
no flags Details | Diff

  None (edit)
Description Andrew Pegram 2008-03-20 17:18:51 EDT
Description of problem:
At (seemingly) random intervals, the rtl8180 driver causes a disconnection
because of a timeout. I have tried to use NDISwrapper with the Windows XP
driver, but this occasionally causes a kernel panic because of Fedora's 4K
stacks. When that program is not causing a panic, it works perfectly, so I
assume that there is a problem with the native rtl8180


Version-Release number of selected component (if applicable):
rtl8180 shipping with kernel-2.6.23-1.fc8.i686 through kernel-2.6.24.3-34.fc8.i686

How reproducible:
I don't know exactly how to reproduce it, but if you connect to a wireless
network, it is bound to happen within fifteen minutes.

Steps to Reproduce:
1. Boot up in the latest kernel (2.6.24.3-34.fc8 at this time)
2. Connect to a wireless with a card using the rtl8180 driver (mine happens to
be a TEW-421PC with an RTL8185 chipset)
3. Wait. (Usually about 5-15 minutes)
  
Actual results:
Disconnection due to timeout (at least, that's what NetworkManager reports)

Expected results:
A steady connection

Additional info:
Sometimes, it will reconnect on it's own, but usually I have to replug the card
to restore the connection. That means on certain segments of my school's
wireless network, I have to reauthenticate, which can take a while. Sometimes
the network disconnects without alerting NetworkManager
Comment 1 Andrew Pegram 2008-03-20 17:20:23 EDT
Let me know what logs I should post, as I have no idea where to look (other than
/var/log/messages, and I saw nothing out of the ordinary there)
Comment 2 John W. Linville 2008-03-24 11:46:26 EDT
Please attach the contents of /var/log/messages anyway, just in case we can 
see something interesting.  If possible, perhaps you can attach a wireshark 
capture taken from another station that shows the time when you disconnect?
Comment 3 Andrew Pegram 2008-03-24 14:08:42 EDT
Created attachment 298914 [details]
/var/log/messages exerpt

Also, when I type ifup wlan0, it gives me this:

Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; No such file or directory.

Determining IP information for wlan0... Done

How would I get a wireshark capture?
Comment 4 John W. Linville 2008-03-24 14:19:47 EDT
The "Set Encode" message is (sadly) normal -- please ignore it.

Please attach the output of running "iwconfig wlan0 scan".  Also, would you 
mind attaching the output of runnign "ps aux"?

Let's hold-off on the wireshark capture for the moment.
Comment 5 Andrew Pegram 2008-03-24 15:23:33 EDT
Created attachment 298921 [details]
First output is while it was disconnected, Second is while connected
Comment 6 Andrew Pegram 2008-03-26 21:11:21 EDT
Just to keep you posted, kernel-2.6.24.3-50.fc8 still has this problem.
Comment 7 John W. Linville 2008-04-15 17:33:09 EDT
There is a patch in the builds here which may address this issue:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=46311

When the build completes, could you give that a try?  Does it help?  Thanks!
Comment 8 Andrew Pegram 2008-04-17 16:19:06 EDT
should I install the debug version, or just the regular?

Comment 9 John W. Linville 2008-04-17 16:22:34 EDT
The non-debug version is fine.
Comment 10 Andrew Pegram 2008-04-17 17:18:12 EDT
nope, same problem. Although I have noticed something odd:

No matter how physically close I get to the router, NM always reports the signal
strength in the range of 22%-27%, and the network speed is usually reported as 1
MB/s. I have rarely seen values outside that range. I don't know if that helps,
but... there it is.
Comment 11 Andrew Pegram 2008-05-27 17:50:35 EDT
This problem still exists in as of 2.6.25.3-18 in Fedora 9. Should I refile the
bug under Fedora 9
Comment 12 John W. Linville 2008-05-30 14:39:46 EDT
I'm not sure of any specific fix, but it might be wortwhile for you to try a
later build:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=50951

Can you recreate this issue with those kernels?
Comment 13 Andrew Pegram 2008-06-03 19:22:11 EDT
Same problem with 2.6.25.4-39.fc9.i686. Although, before, the NM applet would
always register two bars, no matter what. Now, it seems to randomly switch
between one, two, and three bars. I don't know if that means anything, but there
it is.
Comment 14 John W. Linville 2008-09-09 14:59:11 EDT
Is this still an issue in -108 or later?
Comment 15 Andrew Pegram 2008-09-12 22:36:25 EDT
Still an issue in -108. I just downloaded the new 2.6.26 kernel, so I will keep you posted.
Comment 16 John W. Linville 2008-10-07 15:30:56 EDT
Created attachment 319687 [details]
0002-rtl8180-normalize-quality-measurment-for-100-point.patch

Normalize quality values to 100-point scale.
Comment 17 John W. Linville 2008-10-07 15:31:12 EDT
I don't have a good theory on why this would help, but without this patch the driver can report quality levels like "133/100" -- that might be confusing NM and/or wpa_supplicant?

Well, I think it is worth a try -- want to build a kernel w/ this patch applied and give it a shot?
Comment 18 Andrew Pegram 2008-10-09 12:40:43 EDT
I have never compiled a kernel before, but I'd like to give it a try. What do I need?
Comment 19 John W. Linville 2009-02-13 14:49:46 EST
FWIW, the patch from comment 16 never really worked... :-(

I've been using this device with the equivalent of a rawhide kernel lately, and it seems to work alright for me.  Are you still seeing problems with recent kernels?  If so, what is the latest kernel you have tried?
Comment 20 John W. Linville 2009-03-17 13:23:32 EDT
Closed due to lack of response.  Please reopen if/when the requested information becomes available...thanks!

Note You need to log in before you can comment on or make changes to this bug.