Bug 438439 - xenbus driver leaks sysfs device entries for PVFB
xenbus driver leaks sysfs device entries for PVFB
Status: CLOSED DUPLICATE of bug 439182
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Markus Armbruster
Martin Jenner
:
Depends On:
Blocks: 448753 492570
  Show dependency treegraph
 
Reported: 2008-03-20 17:19 EDT by Daniel Berrange
Modified: 2009-05-01 16:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 05:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2008-03-20 17:19:22 EDT
Description of problem:
Create a paravirt guest with the framebuffer configured, and then destroy it
again. The /sys/class/xen-backend/devices/ directory will contain 2 nods for the
VFB and VKBD devices. These nodes never appear to go away.

Version-Release number of selected component (if applicable):
kernel-2.6.18-84.el5

How reproducible:
Always

Steps to Reproduce:
1. Edit /etc/xen/GUEST and add 
2.vfb = [ "type=vnc,vncunused=1"]
3. virsh start GUEST
4. Let it boot
5. virsh destroy GUEST
6. ls /sys/bus/xen-backend/devices/

Actual results:
Two directories are still present:

vfb-DOMID-0
vkbd-DOMID-0

Expected results:
No directories are left behind

Additional info:
Comment 1 Daniel Berrange 2008-03-20 17:22:22 EDT
The problem appears to be with the delegation of responsibility between the
xenbus module, and the backend specific modules.

The sysfs node is added when the xenbus_probe_node() method in the xenbus module
calls device_register().


The corresponding call for device_unregister() though is in th backend specific
modules. eg, the frontend_changed() method in  the blkback module.

There does not appear to be any generic fallback code in xenbus to call
device_unregister() for device's whose backend lives in userspace such as VFB.
Comment 3 RHEL Product and Program Management 2008-07-24 12:11:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Michal Novotny 2009-04-08 11:17:43 EDT
In fact, when you do `xenstore-rm /local/domain/0/backend/{deviceClass}/{domid}` it automatically deletes those files in sysfs. I am working investigating it now...
Comment 7 Michal Novotny 2009-04-09 06:26:39 EDT
I seems to be connected to BZ #439182. I've created and done workaround/patch and posted it to this BZ.
Comment 8 Chris Lalancette 2009-04-10 05:44:53 EDT
I'm going to close this as a dup of 439182, then.  If it turns out to be different, we can re-open.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 439182 ***

Note You need to log in before you can comment on or make changes to this bug.