Bug 438440 - SDL window does not appear for pv guest
SDL window does not appear for pv guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.2
All Linux
low Severity high
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 17:22 EDT by Amy Griffis
Modified: 2009-12-14 16:15 EST (History)
10 users (show)

See Also:
Fixed In Version: RHBA-2008-0305
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:22:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed fix (585 bytes, patch)
2008-04-07 10:16 EDT, Markus Armbruster
no flags Details | Diff

  None (edit)
Description Amy Griffis 2008-03-20 17:22:20 EDT
Description of problem:

When starting a pv guest configured to use SDL, the SDL window fails to open.
The message is:

Error: Device 0 (vkbd) could not be connected. Hotplug scripts not working.

Version-Release number of selected component (if applicable):
5.2beta

How reproducible:
always

Steps to Reproduce:
1. install paravirt guest with vnc
2. add "console=tty console=xvc0" to guest kernel boot params
3. edit guest's xen config: vfb = [ "type=sdl,display=:1.0" ]
4. shutdown, then 'xm create' the guest
  
Actual results:

SDL window does not appear; guest shows up as 'paused' in virtual machine
manager; after un-pausing the guest boots and I can login via the serial
console; shortly afterwards the guest dies and the error listed above is
reported in the dom0 terminal.

Expected results:

This process used to work in 5.1. (You can't install using SDL, so the
workaround is to install using VNC and then switch to SDL.)

Additional info:

Removing /var/lib/xenstored/tdb and rebooting does not change anything.
Comment 1 RHEL Product and Program Management 2008-04-03 15:23:16 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Markus Armbruster 2008-04-04 13:54:13 EDT
Assigning to myself for triage.
Comment 5 Markus Armbruster 2008-04-07 10:16:50 EDT
Created attachment 301521 [details]
Proposed fix
Comment 6 Bill Burns 2008-04-07 10:20:48 EDT
Setting flags.
Comment 10 Chris Lalancette 2008-04-08 15:49:27 EDT
Committed in xen-3.0.3-62.el5:

* Tue Apr  8 2008 Chris Lalancette <clalance@redhat.com> - 3.0.3-62.el5
- Fix pvfb SDL window (rhbz #438440)

Chris Lalancette
Comment 12 Amy Griffis 2008-04-10 17:03:31 EDT
Verified this fix solves the problem.
Comment 14 errata-xmlrpc 2008-05-21 11:22:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0305.html

Note You need to log in before you can comment on or make changes to this bug.