This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 438450 - asus eee uninstallable due to excessive memory use.
asus eee uninstallable due to excessive memory use.
Status: CLOSED DUPLICATE of bug 438377
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 20:03 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-24 16:02:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-03-20 20:03:52 EDT
The Eee 'only' has 512MB, and 4GB of flash, so swap is kind of out of the
question.  The only way I managed to get the installer to complete without
getting oom-killed is by temporarily adding swap on a usb memory stick during
the install.

I'm not sure why our memory usage during install has blown up so dramatically
over the last few releases, but it seems to be getting worse, especially on 'no
swap' machines.

I'm uncertain if the problem is anaconda, or yum at this point, because
debugging the eee is blocked on an intel gfx driver bug that prevents the use of
tty2.

As an absolute worse-case hack we could do swap-on-a-file on the installed
partition if no swap partition is defined. Ugly, but it'd make things succeed
for now.
Comment 1 Jeremy Katz 2008-03-20 23:19:00 EDT
One thing that's hurting us right now is that we're always putting stage2.img
into RAM as a result of the work for stage2=.  Chris is working on fixing that
up.  Beyond that, the biggest thing that's going to be impacting and making us
use more memory is more packages ==> more metadata :-/
Comment 2 Chris Lumens 2008-03-24 16:02:17 EDT

*** This bug has been marked as a duplicate of 438377 ***

Note You need to log in before you can comment on or make changes to this bug.