Bug 438451 - "Application init failed ... This probably means that Tcl wasn't installed properly."
"Application init failed ... This probably means that Tcl wasn't installed pr...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tcltk (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Bill Huang
http://blog.revragnarok.com/blog/wiki...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 20:04 EDT by RevRagnarok
Modified: 2008-04-02 18:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 18:09:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RevRagnarok 2008-03-20 20:04:23 EDT
Description of problem:
The autopath of tcl is not properly being set to something reasonable like
"/usr/share/tcl8.4/tcl8.4" but instead odd-ball things like
"/build/xfndry8/J.36/env/TDS/Tcl/dist/export/lib"

Version-Release number of selected component (if applicable):
tcl-8.4.17-1.fc8
tk-8.4.17-2.fc8


How reproducible:
Every time

Steps to Reproduce:
1. Whenever I tried running a tcl/tk installer that I cannot share
  
Actual results:
"Application init failed ... This probably means that Tcl wasn't installed
properly."

Expected results:
Installer to run.

Additional info:
My ugly solution is found at the URL. But to repeat:
mkdir -p /build/xfndry8/J.36/env/TDS/Tcl/dist/export/lib
cd /build/xfndry8/J.36/env/TDS/Tcl/dist/export/lib
ln -s /usr/share/tcl8.4/tcl8.4 /build/xfndry8/J.36/env/TDS/Tcl/dist/export/lib
cd /usr/lib
mv tk8.4 tk8.4_orig
ln -s /usr/share/tk8.4 tk8.4
cp tk8.4_orig/pkgIndex.tcl tk8.4
Comment 1 Marcela Mašláňová 2008-03-21 04:21:13 EDT
Could you be more precise with steps to reproduce?

We don't support tcl/tk for years. What's tcl/tk installer? Yum install it in
normal path "/usr/share/tcl8.4".
Comment 2 RevRagnarok 2008-03-21 05:42:11 EDT
The installer is a program I got from another company to install their software
that happened to be written in tcl/tk. That was just what I happened to be
executing, sorry for the confusion.

Yum installs into /usr/share/tcl8.4, however the tclsh and wish shells don't
look there, instead they are looking at some weird directory
"/build/xfndry8/J.36/env/TDS/Tcl/dist/export/lib" almost like the rpm build
scripts are broken.
Comment 3 Marcela Mašláňová 2008-03-25 10:22:29 EDT
I read your blogspot ;-) As you are saying, you are using third party program. I
can't test it. Fedora paths are a little different from other distro tcl paths,
because we want libraries in lib and share objects in share. 
But as you can see on my F-8, I can't avoid your problem:
[root@somewhere]# tclsh
% puts $auto_path
/usr/share/tcl8.4 /usr/share /usr/lib /usr/lib/tcl8.4
% exit
[root@somewhere]# rpm -q tcl tk
tcl-8.4.17-1.fc8
tk-8.4.17-2.fc8

Did you try to reinstall tcl? Couldn't be this path added with some tcl module?
Comment 4 RevRagnarok 2008-04-02 18:09:12 EDT
I now see recognize the xfndry8 and J.38 part - it's the Xilinx 8 software that
hosed up my install. Sorry!

Note You need to log in before you can comment on or make changes to this bug.