Bug 438454 - Unknown issues with kernels newer than 2.6.25-0.93.rc4.fc9.
Unknown issues with kernels newer than 2.6.25-0.93.rc4.fc9.
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-20 22:40 EDT by Gideon Mayhak
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-29 06:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/messages immediately after the failure. (2.71 MB, text/plain)
2008-03-21 00:25 EDT, Gideon Mayhak
no flags Details
/var/log/Xorg.0.log immediately after the failure. (52.25 KB, text/plain)
2008-03-21 00:26 EDT, Gideon Mayhak
no flags Details
/var/log/messages after a successful boot. (2.82 MB, text/plain)
2008-03-21 00:28 EDT, Gideon Mayhak
no flags Details
/var/log/Xorg.0.log after a successful boot. (57.11 KB, text/plain)
2008-03-21 00:29 EDT, Gideon Mayhak
no flags Details
This is immediately after the latest type of crash. (1.61 MB, text/plain)
2008-04-08 19:20 EDT, Gideon Mayhak
no flags Details
Again, this is immediately after the latest type of crash. (31.88 KB, text/plain)
2008-04-08 19:21 EDT, Gideon Mayhak
no flags Details
/var/log/messages after a fresh boot into the *216* kernel. (50.58 KB, text/plain)
2008-04-11 19:31 EDT, Gideon Mayhak
no flags Details
Xorg log file (63.48 KB, application/octet-stream)
2008-04-13 08:57 EDT, Mike Chambers
no flags Details
Kernel oops during boot (4.27 KB, text/plain)
2008-04-13 09:01 EDT, Mike Chambers
no flags Details
Xorg Conf file (388 bytes, application/octet-stream)
2008-04-13 09:02 EDT, Mike Chambers
no flags Details
my xorg.conf file (8.80 KB, text/plain)
2008-04-14 05:08 EDT, Aznar
no flags Details
messages log file, nouveau driver, error (154.01 KB, text/plain)
2008-04-14 05:09 EDT, Aznar
no flags Details
lspci, my computer, nouveau driver, GeForce 6100 nForce 430 (rev a2) (1.60 KB, text/plain)
2008-04-14 05:11 EDT, Aznar
no flags Details

  None (edit)
Description Gideon Mayhak 2008-03-20 22:40:09 EDT
Description of problem:
With every kernel after 2.6.25-0.93.rc4.fc9 (including the latest in Koji,
2.6.25-0.133.rc6.git3.fc9), my system fails to load GDM more than half the time
I boot.  If I reboot enough times, I can eventually get to GDM.  Otherwise, I
get a screen with a blinking cursor (or sometimes completely blank).  I am then
able to switch to/from Ctrl+Alt+F1-F6, and back to F7 (which is still blank). 
Sometimes, a few lines of errors regarding my b43 wireless appear.

Version-Release number of selected component (if applicable):
2.6.25-0.93.rc4.fc9 is fine, all others up to 2.6.25-0.133.rc6.git3.fc9 fail
more than half the time.

How reproducible:
Maybe 75% of the time; possibly more.

Steps to Reproduce:
1. Boot
2. Wait for boot process to complete (RHGB and all)
3. Watch GDM not load

Actual results:
GDM does not load.  I receive a blank screen, sometimes with a blinking cursor
and some errors related to b43 wireless, other times just blank.

Expected results:
I expect GDM to load normally, as it does with the 2.6.25-0.93.rc4.fc9 kernel.

Additional info:
I'm really sorry that I can't provide more information, but the only thing I see
is that the kernel change is the only correlation to the problem.  My system is
otherwise up-to-date with rawhide.  The reason I have postponed creating a bug
report for so many kernel releases is that I was hoping it would get better (and
I was ashamed that I couldn't offer more information), but the beta release is
near and I'm worried that the release's kernel won't be everything it can be.  I
was also waiting with the hope that a fresh install from the beta release would
possibly clean up some weird lingering baggage that might be causing the
problem.  One way or another, I decided I really should alert someone about this
odd problem.

Please tell me what information to get you, whether logs or command outputs or
whatever.  I'm really not sure where to start with this one.  My computer is a
stock Compaq F572US; NVIDIA MCP51 chipset with GeForce 6100 and Broadcom BCM4311
rev. 2 wireless.  I can provide more hardware information if you feel it would
be useful.
Comment 1 Dave Jones 2008-03-20 23:46:56 EDT
when it fails in the 'blinking cursor' mode, can you switch to tty1, and log in

Also, please attach /var/log/messages and /var/log/Xorg.0.log
Comment 2 Gideon Mayhak 2008-03-21 00:25:46 EDT
Created attachment 298767 [details]
/var/log/messages immediately after the failure.
Comment 3 Gideon Mayhak 2008-03-21 00:26:27 EDT
Created attachment 298768 [details]
/var/log/Xorg.0.log immediately after the failure.
Comment 4 Gideon Mayhak 2008-03-21 00:28:38 EDT
Created attachment 298769 [details]
/var/log/messages after a successful boot.

After collecting the logs after a failure, I rebooted to have it load GDM, so I
figured I'd attach the logs post-success as well.
Comment 5 Gideon Mayhak 2008-03-21 00:29:56 EDT
Created attachment 298770 [details]
/var/log/Xorg.0.log after a successful boot.

Thanks for pointing me to the right information.  Hopefully we can figure this
out :).
Comment 6 Dave Jones 2008-03-21 11:17:27 EDT
ok, this looks like a nouveau bug. reassigning.
Comment 7 Gideon Mayhak 2008-03-21 13:06:44 EDT
Just to note: I have just downloaded the latest updates for both the kernel and
the nouveau driver, and the problem persists.  After a few reboots, success rate
is around 50%.
Comment 8 Gideon Mayhak 2008-03-25 17:15:08 EDT
Success rate seems to have gotten worse with the last couple kernel updates.  I
will be reinstalling using the Beta DVD once it's finished downloading.  I will
report back once I have done that and let you know if there's any improvement.
Comment 9 Gideon Mayhak 2008-03-28 23:30:16 EDT
I've reinstalled from the beta DVD and it's as bad as ever.  Please let me know
if I can provide you with any more logs or other information.
Comment 10 Gideon Mayhak 2008-03-31 16:12:39 EDT
Are there any thoughts on this?  I notice there haven't been any updates for 
the nouveau package in over half a month.  Have there been any changes upstream?
Comment 11 Gideon Mayhak 2008-04-08 17:06:02 EDT
With the latest packages (*212* kernel and *0408* nouveau), the boot process 
does not even get as far as before.  There is what appears to be a kernel oops 
or panic and I am not able to do anything but Ctrl+Alt+Del to reboot (and 
sometimes it freezes and I can't even do that).  I can try to get some logs 
attached when I get home this evening.
Comment 12 Gideon Mayhak 2008-04-08 19:20:44 EDT
Created attachment 301731 [details]
This is immediately after the latest type of crash.
Comment 13 Gideon Mayhak 2008-04-08 19:21:55 EDT
Created attachment 301732 [details]
Again, this is immediately after the latest type of crash.
Comment 14 Gideon Mayhak 2008-04-09 12:29:31 EDT
And I still get a crash with kernel *216*.
Comment 15 Chuck Ebbert 2008-04-10 19:05:37 EDT
Can you post the oops message from kernel 216? I have the debuginfo for that
Comment 16 Gideon Mayhak 2008-04-11 19:31:00 EDT
Created attachment 302180 [details]
/var/log/messages after a fresh boot into the *216* kernel.

Please let me know if you need other information than this.  I'm not entirely
familiar with where various error messages are stored, but I do see a line with
an oops code in this file.
Comment 17 Mike Chambers 2008-04-13 08:56:56 EDT
Not sure if this is the same, but I just tried using this driver for the first
time and got a backtrace while booting.  I will attach the oops as as well as my
xorg log file and xorg conf file.

Just a side note, my system is auto detected using nv, but wanted to try out
this driver to see what the fuss was about and if it was any better.
Comment 18 Mike Chambers 2008-04-13 08:57:50 EDT
Created attachment 302263 [details]
Xorg log file
Comment 19 Mike Chambers 2008-04-13 09:01:12 EDT
Created attachment 302264 [details]
Kernel oops during boot
Comment 20 Mike Chambers 2008-04-13 09:02:46 EDT
Created attachment 302265 [details]
Xorg Conf file
Comment 21 Gideon Mayhak 2008-04-13 16:26:00 EDT
Yeah, nv works fine and was default for me, as well.
Comment 22 Aznar 2008-04-14 05:08:24 EDT
Created attachment 302317 [details]
my xorg.conf file

Hi, same issue here. I provide more info, may-be it will help you.

It would be great to be able to submit multiple files at the same time...
Comment 23 Aznar 2008-04-14 05:09:38 EDT
Created attachment 302318 [details]
messages log file, nouveau driver, error

My message log file
Comment 24 Aznar 2008-04-14 05:11:03 EDT
Created attachment 302320 [details]
lspci, my computer, nouveau driver, GeForce 6100 nForce 430 (rev a2)

the output of lspci : my card GeForce 6100 nForce 430 (rev a2)
Comment 25 Gideon Mayhak 2008-04-15 21:10:28 EDT
Things are working again with kernel *231*!  Feel free to close this or wait for
a confirmation from Mike Chambers and Aznar.  Everything seems bright and sunny
on my end :).
Comment 26 Mike Chambers 2008-04-16 05:56:59 EDT
Correct, driver works here on my end with the .234 kernel.  I didn't try the
other one as found this one more updated on koji instead of .231
Comment 27 Matěj Cepl 2008-04-16 09:52:17 EDT
Aznar, could you please confirm, that the issue has been resolved?

Thank you.
Comment 28 Gideon Mayhak 2008-04-16 16:03:33 EDT
Mike, *234* was still building when I got *231*.  I'll have to update :D.
Comment 29 Mike Chambers 2008-04-29 06:42:41 EDT
I'd say that this bug has been fixed and no longer needs to be open? Gonna close
it with no objections.

Note You need to log in before you can comment on or make changes to this bug.