Bug 438525 - Command-Line attachmet is broken
Command-Line attachmet is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-21 09:54 EDT by Reindl Harald
Modified: 2008-11-26 12:37 EST (History)
2 users (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 12:37:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of non-reproducing this bug (128.08 KB, image/png)
2008-03-21 11:52 EDT, Matěj Cepl
no flags Details
Thunderbird running (68.24 KB, image/png)
2008-03-21 19:45 EDT, Reindl Harald
no flags Details
Thunderbird not running (70.16 KB, image/png)
2008-03-21 19:47 EDT, Reindl Harald
no flags Details

  None (edit)
Description Reindl Harald 2008-03-21 09:54:00 EDT
Hi

The Fedora-Build of Thunderbird is broken since a long time and i would like to
use yum instead of taraballs from mozilla.org

I have a .desktop-File and a PHP-Script what makes the call to thunderbird
running under KDE, it works perfectly with the original-tarball, but iwth the
fedora-builds it results in a
"attachment='file:///home/harry/.kde/share/icons/thunderbird.xpm'" in the
To-Field instead attaching files :-(

I wonder that nobobody uses context-menu for attaching files to emails...

___

[Desktop Entry]
Encoding=UTF-8
ServiceTypes=all/all
Actions=attachToEmail

[Desktop Action attachToEmail]
Name=Attach to e-mail
Name[la]=Annectere ad e-litteras
Name[de]=An E-Mail anhängen
Name[pt_BR]=Enviar por e-mail como anexo
Name[nl]=Verzend als bijlage per e-mail
Name[es]=Enviar por correo
Name[nb]=Vedlegg til e-post
Name[nn]=Vedlegg til e-post
Name[fr]=Envoyer par email
Icon=attach
Exec=~/.kde/share/apps/konqueror/servicemenus/send-file.php %U
________________

#!/usr/bin/php
<?php
 $cmd = 'thunderbird -compose "attachment=\'';
 settype($_SERVER['argv'], 'array');
 $set_comma = 0;
 foreach($_SERVER['argv'] as $file)
 {
  if(basename($file) != 'send-file.php')
  {
   if($set_comma)
   {
    $cmd .= ',';
   }
   $cmd .= 'file://' . escapeshellcmd($file);
   $set_comma = 1;
  }
 }
 $cmd .= '\'"';
 exec($cmd);
?>
Comment 1 Matěj Cepl 2008-03-21 11:52:08 EDT
Created attachment 298795 [details]
screenshot of non-reproducing this bug

So, just to make some order from this very convoluted and obviously complex
problem, you mean that running command

thunderbird -compose "attachment=file:///home/matej/any2theora.sh"

(which is at least I hope what your PHP script tries to do; I don't know PHP
and I don't like it, so I have never learnt it well)

so that running this command should open TB composer with the file attached?
Well, it works for me.

Do you have something more to add to it before I close this bug as WORKSFORME?
Comment 2 Matěj Cepl 2008-03-21 11:53:31 EDT
Or in less argumentative style -- what does running the above command does on
your computer?
Comment 3 Reindl Harald 2008-03-21 19:45:42 EDT
Created attachment 298814 [details]
Thunderbird running
Comment 4 Reindl Harald 2008-03-21 19:47:09 EDT
Created attachment 298815 [details]
Thunderbird not running
Comment 5 Reindl Harald 2008-03-21 19:53:17 EDT
I have postetd two screenshots
The bug hits only if thunderbird is running sending the command
If thunderbird is started with a command like  
thunderbird -compose "attachment='file:///home/harry/php_error.log'"
it works as it should be

If i use the mozilla.org-Tarball there are no troubles

_________

History of this:

* There was a known bug in thunderbird 1.5.x
* As thunderbird 2.0 beta was released i wrote the php-skript and depsktop-file
* As fedora packaged thunderbird 2.0.x i tried the ditribution-build
* Had the same error, becaue my mail-client is running all the day
* Now we know whatever is buggy, it is only if the apllication runs

I hope you can reprdouce and fix this
My normal stard-command is "ksystraycmd kgtk-wrapper thunderbird" just for your
info, does not matter at this time, but please test it also while trying to fix
Comment 6 Martin Stransky 2008-03-25 13:39:27 EDT
I think it's already fixed in rawhide.
Comment 7 Reindl Harald 2008-03-25 14:07:50 EDT
Can anybody fix this also in F8?

This is a bug that has gone away upstream with the first beta auf TB 2.0.x and
only the fedora-builds will bring him back - its enough to must make an own hack
in kde because there is no context-menu "send mail" using the selected MUA, but
if   it does not work finally it hurts :-(

I love Fedora, but such bugs in TB and the fact that some FF-Extensions
(https://bugzilla.redhat.com/show_bug.cgi?id=432728) does not work while
mozilla.org-builds have no problems is a big pain! 
Comment 8 Martin Stransky 2008-03-26 03:54:52 EDT
We can bundle it to some upcoming security errata...
Comment 9 Martin Stransky 2008-03-26 10:20:58 EDT
The fix is in CVS and will be released with the next security update
(thunderbird-2.0.0.13).
Comment 10 Bug Zapper 2008-11-26 05:14:34 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Jon Stanley 2008-11-26 12:37:32 EST
As this bug is in MODIFIED, Fedora believes that a fix has been committed that resolves the problem listed in this bug report.

If this is not the case, please re-open this report, noting the version of the package that you reproduced the bug against.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.