Bug 438527 - Bibus fails to connect with OpenOffice
Bibus fails to connect with OpenOffice
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bibus (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On: 450692
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-21 09:57 EDT by Manuel Morales
Modified: 2009-10-09 17:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 02:11:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manuel Morales 2008-03-21 09:57:01 EDT
Description of problem:
After installing Bibus, I am unable to connect to OpenOffice. Note that this
functionality is present if I use the source code from Sourceforge.

Version-Release number of selected component (if applicable):
bibus-1.4.1-4.fc8

How reproducible:
Always

Steps to Reproduce:
1.Go to Edit -> preferences. Select Advanced preferences and then click on 'Word
Processor' tab.
2.Choose OpenOffice for the Word Processor with "Use a pipe" option.
3.Click OK.
  
Actual results:
Changes do not take effect.

Expected results:
Connection to OpenOffice established, as after installing Bibus from source.

Additional info:
Comment 1 Alex Lancaster 2008-03-24 03:48:36 EDT
Did you run the "First Connection Wizard" and select OpenOffice.org in the first
screen then click "Activate" to run Writer and follow the instructions in the
document that opens?  

Once potential wrinkle is that you have allow macros to run by going to
Options->Security->Macro Security in OOo and select "Medium" security level to
allow the document to setup the pipe correctly.
Comment 2 Alex Lancaster 2008-03-24 03:49:58 EDT
Also in order to insert citations into a document you have to have already
opened a Writer doc.  (This is the case with both the source install and with
the Fedora RPM).
Comment 3 Manuel Morales 2008-03-24 08:28:01 EDT
The problem seems to be that the path for OpenOffice is set in
/usr/share/bibus/bibus.cfg to /usr/lib/openoffice.org/program/. On x86_64
installations, lib should be lib64 instead. Editing this line fixed the problem
for me.
Comment 4 Alex Lancaster 2008-03-24 08:37:14 EDT
Thanks!  The .spec file had to do some contortions on the upstream Makefile as
it is so non-standard (I wish the upstream authors had used the standard Python
dist-utils instead of a dodgy hand-rolled Makefile).  In any case it appears I
neglected to account for the x86_64 /usr/lib64 issue.  

I'll try and push an update to updates-testing fixing this real soon now. 
Please do check once push (there'll be an automatic status update on this bug
once pushed).
Comment 5 Alex Lancaster 2008-03-24 08:57:02 EDT
Erk, not as easy as I thought.  The problem is that the package is noarch, so at
build-time it can't know which platform it will be installed, and therefore
can't know which prefix to use in /usr/share/bibus/bibus.cfg:

  oopath = /usr/lib/openoffice.org/program/
  oopath = /usr/lib64/openoffice.org/program/

One solution would be to make the package arch-specific so that it can pick up
the lib64 directory at build-time and have a x86_64 package, but that seems
unnecessarily redundant.   Another would be to make bibus smarter about looking
for OOo, which is probably the right way, but I don't have time to dive into
bibus internals right now.

I'm Cc'ing the openoffice maintainer to see if he has any ideas/workarounds.
Comment 6 Alex Lancaster 2008-06-10 05:50:52 EDT
Currently working on this, my workaround is going to be making it arch-specific.

I'm filing this bug upstream in the hope that bibus can be made smarter:

http://sourceforge.net/tracker/index.php?func=detail&aid=1989580&group_id=110943&atid=657832
Comment 7 Fedora Update System 2008-06-10 06:58:19 EDT
bibus-1.4.3-1.fc9 has been submitted as an update for Fedora 9
Comment 8 Fedora Update System 2008-06-10 06:59:46 EDT
bibus-1.4.3-1.fc8 has been submitted as an update for Fedora 8
Comment 9 Alex Lancaster 2008-06-10 09:51:20 EDT
Long-term the solution should be to add pyuno to the default Python namespace so
that "import pyuno" "just works" without having to specifically set a path to
it.  I filed bug #450692 for this purpose.
Comment 10 Fedora Update System 2008-06-11 00:34:02 EDT
bibus-1.4.3-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5181
Comment 11 Fedora Update System 2008-06-12 22:18:41 EDT
bibus-1.4.3-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-06-12 22:18:58 EDT
bibus-1.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Ville Skyttä 2008-07-03 14:31:34 EDT
(In reply to comment #6)
> Currently working on this, my workaround is going to be making it arch-specific.

A minor issue caused by this: it now produces a useless empty debuginfo package.
Fix: "%define debug_package %{nil}"
Comment 14 Daniel 2009-10-09 17:44:51 EDT
(In reply to comment #12)
> bibus-1.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If
> problems still persist, please make note of it in this bug report.  

-----

Still present in Fedora 11 i586, bibus-1.4.3-1.fc11, openoffice.org-writer-1:3.1.1-19.2.fc11.

    Cannot connect to Openoffice. See Documentation.
    Cannot connect to Openoffice. See Documentation.
    Connector : couldn't connect to pipe OOo_pipe(10))

oopath variable is correct, as follows:

File: /usr/share/bibus/bibus.cfg                                          

    [PATH]
    python = /usr/bin/python
    oopath = /usr/lib/openoffice.org3/program/
    ooure = /usr/lib/openoffice.org/basis3.0/ure-link/lib
    oobasis = /usr/lib/openoffice.org/basis3.0/program
    docdir = //usr/share/doc/bibus-1.4.3.1/html
    licence = //usr/share/doc/bibus-1.4.3.1/copying
    localedir = //usr/share/locale
    systemconf = /etc/bibus.config

OOo Macro Security settings have been dropped to "Medium". No love.

Note You need to log in before you can comment on or make changes to this bug.