Bug 438534 - Installed documentation not available from inside Geany
Installed documentation not available from inside Geany
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: geany (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-21 10:38 EDT by Enrico Tröger
Modified: 2008-07-21 12:49 EDT (History)
0 users

See Also:
Fixed In Version: 0.13-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 12:49:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Tröger 2008-03-21 10:38:28 EDT
A user just reported me a problem with Geany on Fedora 8:
the HTML documentation is installed in /usr/share/doc/geany-0.13/html but Geany
expects it at /usr/share/doc/geany/html. So, Geany can't find the installed
documentation and falls back to the online documentation(on Geany's website).

It would be better if you(package maintainer) would install the documentation in
/usr/share/doc/geany/ or at least patch setup_paths() in src/main.c to reflect
the  changed documentation directory.

To avoid such problems in the future, Geany now(current development version and
upcoming 0.14 release) respects and uses the --docdir option when passed to
configure. So, when building it the next time, use the --docdir option (if not
already).

Thanks.
Comment 1 Jonathan Underwood 2008-03-21 18:35:25 EDT
Yes - I too had spotted this, but may wait for the 0.14 release in any case to
fix this, as that brings the possibility of easier building of plugins as well,
and I've been working on changes needed for that as a higher priority. Thanks
for the report - since it's actually bothering a user now, I'll try and get
around to a fixed package for 0.13 in a few days.
Comment 2 Fedora Update System 2008-03-24 09:57:59 EDT
geany-0.13-2.fc7 has been submitted as an update for Fedora 7
Comment 3 Fedora Update System 2008-03-24 09:59:16 EDT
geany-0.13-2.fc8 has been submitted as an update for Fedora 8
Comment 4 Enrico Tröger 2008-03-24 13:11:57 EDT
Thanks for the quick fix.
Comment 5 Fedora Update System 2008-03-26 13:17:06 EDT
geany-0.13-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update geany'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2725
Comment 6 Fedora Update System 2008-04-01 17:31:43 EDT
geany-0.13-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-04-01 17:37:12 EDT
geany-0.13-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.