Bug 438541 - clamav api change breaks klamav build
clamav api change breaks klamav build
Status: CLOSED DUPLICATE of bug 438627
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-21 12:01 EDT by Dhaval Giani
Modified: 2008-03-28 01:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 01:50:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhaval Giani 2008-03-21 12:01:56 EDT
Description of problem:
[root@mordor ~]# yum install klamav
does not work. unresolved dependency

[root@mordor ~]# yum install klamav

Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package klamav.i386 0:0.42-1.fc9 set to be updated
--> Processing Dependency: libclamav.so.3 for package: klamav
--> Processing Dependency: clamav >= 0.90 for package: klamav
--> Processing Dependency: clamav-update >= 0.90 for package: klamav
--> Running transaction check
---> Package clamav-update.i386 0:0.93-0.0.rc1.fc9 set to be updated
--> Processing Dependency: libclamav.so.4(CLAMAV_PUBLIC) for package: clamav-update
--> Processing Dependency: libclamav.so.4 for package: clamav-update
--> Processing Dependency: libclamav.so.4(CLAMAV_PRIVATE) for package: clamav-update
--> Processing Dependency: group(clamav) for package: clamav-update
--> Processing Dependency: clamav-filesystem = 0.93-0.0.rc1.fc9 for package:
clamav-update
---> Package clamav.i386 0:0.93-0.0.rc1.fc9 set to be updated
--> Processing Dependency: data(clamav) for package: clamav
---> Package klamav.i386 0:0.42-1.fc9 set to be updated
--> Processing Dependency: libclamav.so.3 for package: klamav
--> Running transaction check
---> Package clamav-lib.i386 0:0.93-0.0.rc1.fc9 set to be updated
---> Package clamav-data.i386 0:0.93-0.0.rc1.fc9 set to be updated
---> Package klamav.i386 0:0.42-1.fc9 set to be updated
--> Processing Dependency: libclamav.so.3 for package: klamav
---> Package clamav-filesystem.i386 0:0.93-0.0.rc1.fc9 set to be updated
--> Finished Dependency Resolution
klamav-0.42-1.fc9.i386 from rawhide has depsolving problems
  --> Missing Dependency: libclamav.so.3 is needed by package
klamav-0.42-1.fc9.i386 (rawhide)
Error: Missing Dependency: libclamav.so.3 is needed by package
klamav-0.42-1.fc9.i386 (rawhide)
[root@mordor ~]#
Comment 1 Rex Dieter 2008-03-21 12:47:16 EDT
Looks like a rebuild attempt was made recently,
https://koji.fedoraproject.org/koji/buildinfo?buildID=41609
but if failed.

Unfortunately, koji doesn't seem to have the logs for that build, so I can't 
comment on how/why it failed.
Comment 2 Rex Dieter 2008-03-21 12:59:07 EDT
Here's how a local build failed (for me):
if 
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/include/kde -I/usr/lib/qt-3.3/include -I.   -DQT_THREAD_
SUPPORT  -D_REENTRANT  -O2  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT 
options.o -
MD -MP -MF ".deps/options.Tpo" -c -o options.o options.c; \
        then mv -f ".deps/options.Tpo" ".deps/options.Po"; else 
rm -f ".deps/options.Tpo"; exit 1; fi
...
clamdmail.c:210: error: 'struct cl_limits' has no member named 'maxmailrec'
clamdmail.c:211: error: 'struct cl_limits' has no member named 'maxratio'
...
make[4]: Leaving directory 
`/Net/mathstat/Users/Staff/rdieter/cvs.fedoraproject.org/klamav/devel/klama      
Comment 3 Rex Dieter 2008-03-21 13:40:38 EDT
erg, looks like clamav changed the api by removing variables (see above) and 
methods (cli_dbgmsg gone missing too?), which is not easy/obvious for my 
non-clamav-dev trained eye to spot and fix.
Comment 4 Rex Dieter 2008-03-21 14:00:34 EDT
bouncing to clamav folks to see what they have to say.
Comment 5 Kevin Kofler 2008-03-28 01:50:03 EDT
I have a patch for klamav.

*** This bug has been marked as a duplicate of 438627 ***

Note You need to log in before you can comment on or make changes to this bug.