Bug 438553 - kernel 2.6.25-x prohibit mounting of LUKS device via gnome-mount
kernel 2.6.25-x prohibit mounting of LUKS device via gnome-mount
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-21 17:06 EDT by Jens Lautenbacher
Modified: 2009-07-14 11:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 11:43:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from kernel 2.6.23 (2.31 KB, text/plain)
2008-03-21 17:06 EDT, Jens Lautenbacher
no flags Details
output from hal-deveice on kernel 2.6.24 (1.36 KB, text/plain)
2008-03-21 17:07 EDT, Jens Lautenbacher
no flags Details

  None (edit)
Description Jens Lautenbacher 2008-03-21 17:06:24 EDT
with the two last updated kernels 2.6.24.3-12 and ...-34, gnome no longer mounts
my luks encrypted USB disks.

Everything works with 2.6.23-137.

It also works to mount the devices by hand.

What actually works, is that the
/dev/mapper/luks_crypto_114e0067-d68a-4909-b855-6513959ca9c1  node is
automatically created whenever I connect the USB disk. But the system doesn't
continue to mount this device. It works to simply mount it by hand. In other
words, the setting up of the mapper file (and the usage of the key from gnome
keyring) works.

I tried to investigate what differs between 2.6.23 and 2.6.24, and it seems that
the output from hal-device is significantly different. I attach the differing
sections below.

The rest of the system is up-to-date as of 2008-03-21
Comment 1 Jens Lautenbacher 2008-03-21 17:06:24 EDT
Created attachment 298809 [details]
output from kernel 2.6.23
Comment 2 Jens Lautenbacher 2008-03-21 17:07:12 EDT
Created attachment 298810 [details]
output from hal-deveice on kernel 2.6.24
Comment 3 Chuck Ebbert 2008-03-26 16:33:11 EDT
Please try 2.6.24.3-50
Comment 4 Jens Lautenbacher 2008-03-26 18:30:34 EDT
nothing changed with *-50. This was a complete shot in the dark, wasn't it :-)
Comment 5 Jens Lautenbacher 2008-03-26 18:32:28 EDT
one more piece of information: nautilus (in the computer view) shows the volume
but it's not automounted. Clicking on the volume to force it to mount will
result in the volume to simply vanish from the view without any error popup or
the like. Of course it's also not mounted...
Comment 6 Jens Lautenbacher 2008-05-25 09:06:06 EDT
This is still the case with Fedora 9. Actually it startet to work again with the
latest kernels under Fedora 8, but I am no longer sure if it really worked
reliable and reproducible... unfortunately I no longer have the Fedora 8
installation (for obvious reasons...).

The situation now is that it occasionally but very, very seldom actually works -
but even when it works, unmounting and re-inserting the USB disk will not work
again. 

It seems that it is also somehow hardware dependent, as another machine in the
office didn't seem to have this problem.

If someone would tell me what kind of data is needed to track down the problem,
I am more than willing to invest quite a lot of time into this - but I am unable
to hep without any guidance unfortunately.
Comment 7 Jens Lautenbacher 2008-05-25 13:53:14 EDT
I have just installed kernel-2.6.23.1-26.fc8.i686 to check with this one, and it
still works under fedora 9 mounting/unmounting the luks encrypted usb hard disk.
Comment 8 Bug Zapper 2009-06-09 19:49:30 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-07-14 11:43:02 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.