Bug 438573 - Dom0 stops writing to serial console
Dom0 stops writing to serial console
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 01:03 EDT by Jeffrey Needham
Modified: 2009-12-14 16:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 16:20:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Needham 2008-03-22 01:03:33 EDT
Description of problem:
When booting a machine enabled for serial console use, xen does not write to the
console during the boot.

Version-Release number of selected component (if applicable):
0303 build of the -83 kernel

How reproducible:
configure the serial port in BIOS, making sure to DISABLE console redirection
after boot (so 2.6 can take over). Mine was wired for 38400, RTS/DTS, direct,
8/1/none

using minicom (or some such) and a null modem cable, hook up the serial port, so
you can observe the output.



Steps to Reproduce:
1. configure /etc/inittab with a line like:
s0:2345:respawn:/sbin/agetty -L -f /etc/issueserial 38400 ttyS0 vt100

add "console=ttyS0, 38400 to both the xen and non-xen kernel entries
2. Boot the machine with the xen kernel
3. Boot the machine with the regular kernel
  
Actual results:
When booting with the xen kernel, nothing gets written to ttyS0 after the
'initrd' message. However, it works fine with the bare iron kernel.



Expected results:


Additional info:
Comment 1 Chris Lalancette 2008-03-22 08:27:33 EDT
Hm, what do you mean by "nothing gets written to ttyS0 after the 'initrd'
message"?  Which initrd message are you talking about?

This is almost certainly a configuration issue, since the Xen serial console
behaves in different ways from the bare metal kernel.  Basically what happens is
that the hypervisor is in control of the serial hardware, and emulates one so
that the dom0 kernel can also read/write to it.  So what you need for
configuration in /boot/grub/grub.conf is:

title Red Hat Enterprise Linux Server (2.6.18-84.el5xen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-84.el5 com1=115200,8n1
        module /vmlinuz-2.6.18-84.el5xen ro root=/dev/HostGroup/RHEL5_x86_64
console=tty0 console=ttyS0,115200
        module /initrd-2.6.18-84.el5xen.img

Notice that the hypervisor line uses the "com1" syntax.  Also notice that INIT
messages all go out to the *last* console you specify, namely console=ttyS0,
etc.  Finally, if you had secondary serial port on this machine, you would
change the HV configuration to something like "com2=115200,8n1 console=com2L",
but you would *not* change the kernel line (it would still be ttyS0).  This is
because the serial port is emulated to the dom0.

Make sure all of the above makes sense to you, and make sure you have it
configured correctly; it is one of the hard things to get right when using Xen
initially.

Chris Lalancette
Comment 2 Jeffrey Needham 2008-03-22 17:58:54 EDT
will give it a shot and get back to you
thanks chris
Comment 3 Jeffrey Needham 2008-03-25 15:51:54 EDT
the above changes worked.

bug can be closed or withdrawn.
Comment 4 Chris Lalancette 2008-03-25 16:20:42 EDT
OK, cool.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.