Bug 438593 - 2.6.24 kernel with radeon hangs / freezes
2.6.24 kernel with radeon hangs / freezes
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-22 11:38 EDT by Mads Kiilerich
Modified: 2009-02-09 14:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-09 14:20:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg from 2.6.23 to show the hardware configuration (23.90 KB, text/plain)
2008-03-22 11:38 EDT, Mads Kiilerich
no flags Details
kernel-messages from /var/log/messages from crash at approx Apr 6 20:46. (50.96 KB, text/plain)
2008-04-06 19:38 EDT, Mads Kiilerich
no flags Details
/var/log/Xorg.0.log.old found efter freeze and alt-sysreq-b (93.82 KB, text/plain)
2008-04-06 19:39 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2008-03-22 11:38:13 EDT
Description of problem:
On my Dell Latitude D610 with Radeon 300 all released 2.6.24 kernels are very
Especially when watching TV the system crashes within minutes.
2.6.23 is quite stable.

Version-Release number of selected component (if applicable):

How reproducible:
I can reproduce the problem but don't have a specific test case. I would be
happy to test fixes and new kernel builds.

Steps to Reproduce:
Run Zattoo player (proprietary media player running in userspace without
privileges) and the system crashes within minutes.
Actual results:
Most of the time static colored vertical stripes are shown and the system
doesn't respond to capslock or sysreq.

A couple of times I think I have experienced that the picture froze, but the
mouse was still alive and sound continued to play for a minute - then it stopped.

Additional info:
The system runs a bit hot, but not more than with 2.6.23. When booting up in
2.6.23 immediately after a crash it works fine.

As it seems to be video related depends on the kernel version and can cause the
system to lock up then I think it might have something with the radeon module.

When I'm careful about which applications I use then 2.6.24 can run for hours.

A minor detail which might be relevant ... or not: I'm using an external display
, but haven't been able to get different output on the screens - except that
some kind of video sometimes only appears on the builtin display and not on the
external. As if some kind of graphic routing isn't initialized properly ...
Comment 1 Mads Kiilerich 2008-03-22 11:38:13 EDT
Created attachment 298842 [details]
dmesg from 2.6.23 to show the hardware configuration
Comment 2 Dave Airlie 2008-03-26 19:18:18 EDT
ouch.. does anything get logged in xorg.log?

I'm not sure of anything in the drm that has changed that could cause this, can
you attach an xorg log file from 2.6.23 and 2.6.24 maybe and we'll start from that..
Comment 3 Mads Kiilerich 2008-04-06 19:36:00 EDT
Sorry for late reply. I have tried to nail it down and get a good test case. But
no success - only this: seemed better; apparently it could run longer before crashing. But
even with I get crashes. 

It can run fine for days as long as I don't stress it with moving pictures.

I feared that it could be overheating somehow. But now I'm running my 1.86 GHz
cpu at 1.07 GHz, using cpuspeed MAX_SPEED. The machine seem not to get as hot as
before - but still it crashes. It takes some minutes before 2.6.24 crashes, but
immediately after a 2.6.24 crash I can boot up in 2.6.23 and it works
flawlessly. So I think that excludes overheating.
Comment 4 Mads Kiilerich 2008-04-06 19:38:01 EDT
Created attachment 301447 [details]
kernel-messages from /var/log/messages from crash at approx Apr 6 20:46.
Comment 5 Mads Kiilerich 2008-04-06 19:39:19 EDT
Created attachment 301448 [details]
/var/log/Xorg.0.log.old found efter freeze and alt-sysreq-b
Comment 6 Mads Kiilerich 2008-04-15 18:12:21 EDT
Well ... It might be heating-related anyway ... I have experienced lockup with
2.6.23, and have also seen 2.6.24 run longer than usually.

At the moment I think that downclocking with cpuspeed significantly improves the
stability. And I think that running with xrandr dualscreen also have improved
2.6.24 stability. Once. Perhaps.

At the moment my best guess is that 2.6.24 is more effective and stresses the
machine more than 2.6.23. But if linux previously didn't stress machines more
than they could handle and now stress them so much that some are unstable, then
it could be considered a regression bug.
Comment 7 Chuck Ebbert 2008-04-18 18:17:45 EDT
Unfortunately there is nothing in those attachments but normal messages.
Comment 8 Mads Kiilerich 2008-05-01 08:32:28 EDT
A consistent pattern appears:
Because 2.6.24 consistently crashed I have been using kernel-
with cpuspeed-downclocked to 1.07 instead of 1.87 GHz. This setup works fine as
long as the machine isn't suspended. After suspend/resume the display hangs when
Zattoo starts showing video.  The machine keeps running - at least system
services not using the display. Keyboard doesn't respond to caps-lock but
alt-sysreq-b works.

But now with kernel- (or other system updates?) it seems to work,
even after suspend/resume. Great! I'm not aware of any changes that explains the
changed behaviour. I will keep testing and follow up here.
Comment 9 Mads Kiilerich 2008-05-27 18:06:59 EDT
Naaah. An hour after I reported that it worked with kernel- I got
a crash again.

I have now upgraded to Fedora 9, and generally (except for minor but annoying
sound hiccups about once a second) it works fine. 

BUT I have experienced the same crash with And I also got
a similar crash where the system started trashing the disk while working without
increased load or memory usage, ending with the wellknown freeze. And once I got
a freeze where the sound continued to play but with huge hiccups or echos.
Comment 10 François Cami 2009-02-09 11:35:16 EST
Could you test with current F10 ?
If you can reproduce with the latest F10 kernel, could you post dmesg as uncompressed text attachment here ? Thanks
Comment 11 Mads Kiilerich 2009-02-09 14:20:54 EST
I don't use that application any longer.

I just installed it again, and it seemed to work just fine with current F10.

So I will assume that it has been solved and will close this issue.

Note You need to log in before you can comment on or make changes to this bug.