This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 438607 - pidgin segfaults after NetworkManager restores connection after resume
pidgin segfaults after NetworkManager restores connection after resume
Status: CLOSED DUPLICATE of bug 436631
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 15:36 EDT by Chris Snook
Modified: 2008-04-01 09:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 09:13:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Snook 2008-03-22 15:36:20 EDT
Description of problem:
To work around a wireless problem that causes NetworkManager to take a few
minutes to reconnect after suspend/resume, I run the following script after resume:

#!/bin/bash
service NetworkManager stop
service NetworkManagerDispatcher stop
modprobe -r iwl3945
modprobe iwl3945
service NetworkManagerDispatcher start
service MetworkManager start

Version-Release number of selected component (if applicable):
pidgin-2.4.0-1.fc8
libpurple-2.4.0-1.fc8
NetworkManager-0.7.0-0.6.7.svn3235.fc8

How reproducible:
60%

Steps to Reproduce:
1. Connect to internet with NetworkManager
2. start pidgin
3. suspend system
4. resume system (reproduces better if the system is asleep for some time)
5. run wireless reset script
  
Actual results:
1. pidgin segfaults as soon as NetworkManager completes configuring the
connection with DHCP

Expected results:
1. pidgin does not segfault

Additional info:
1. I did not notice this problem happening before I added the
NetworkManagerDispatcher steps to the script, but this may have been a
coincidence, since it's not 100% reproducible, and the segfault appears as
pidgin silently going away.
Comment 1 Chris Snook 2008-03-22 19:20:37 EDT
Woah, just died again, this time after a resume when NetworkManager was able to
restore the wireless connection immediately, without running the script.  I just
realized that I don't think I ever saw this with the previous version of pidgin,
so the addition of the NetworkManagerDispatcher logic in my script may be a pure
coincidence.  It's looking now like the new reconnect logic in pidgin is the
culprit.
Comment 2 Chris Snook 2008-03-23 01:20:40 EDT
New failure mode: pidgin segfaults as soon as NetworkManager is restarted
*before* it brings up the connection.

Bottom line, pidgin does not like NetworkManager restarts at all.
Comment 3 Stu Tomlinson 2008-03-23 12:29:45 EDT
This is probably a duplicate of bug 436641 but to confirm please install the
debuginfo packages (with "debuginfo-install pidgin") and get a backtrace as
described on http://fedoraproject.org/wiki/StackTraces
Comment 4 Chris Snook 2008-03-23 15:28:08 EDT
Ummm... that's a touchpad bug.  My touchpad is disabled in the BIOS, and has
been since before I did this install.  Nothing on my system should be doing
anything touchpad-related.
Comment 5 Chris Snook 2008-03-23 18:39:32 EDT
It gets weirder.  A couple of times it has died several seconds after
NetworkManager has finished bringing up the connection.  Once was without
needing to run the script.  Pidgin reconnects to all my services, and then
suddenly disappears a few seconds later.

Something's just borked in the new pidgin connection restore code.
Comment 6 Stu Tomlinson 2008-03-23 22:06:17 EDT
Sorry, typo, I meant bug 436631. Still waiting for the backtrace.
Comment 7 Chris Snook 2008-03-31 21:21:43 EDT
Yes, this does appear to be a duplicate of 436631.  I am using AIM and Google
Talk  I get no backtrace on the console.  Are you asking for a core?  I can do that.
Comment 8 Stu Tomlinson 2008-04-01 09:13:27 EDT

*** This bug has been marked as a duplicate of 436631 ***

Note You need to log in before you can comment on or make changes to this bug.