Bug 438616 - WM5 device crashes USB
WM5 device crashes USB
Status: CLOSED DUPLICATE of bug 442253
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-22 19:37 EDT by James Gregory
Modified: 2008-04-18 18:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 18:22:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt from "messages" showing rndis_host bug trace (5.32 KB, text/plain)
2008-03-22 19:37 EDT, James Gregory
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 7201 None None None Never

  None (edit)
Description James Gregory 2008-03-22 19:37:50 EDT
Description of problem:
I have an O2 Xda Mini S running Windows Mobile 5. I often use the USB port of my
laptop to charge up the phone, but I don't want RNDIS to attach it and attempt
to connect to it (RNDIS also breaks my ability to connect to it through VMware).
In my rc.local, I have the following:
/sbin/modprobe -r -v rndis_host ipaq cdc_ether usbserial usbnet
This supposedly unloads the rndis support so that the driver won't be loaded
when I attach my device. However, this seems to be being ignored because after a
few times of connecting the device, it appears that rndis_host crashes and
causes USB support to completely die until I reboot (see the attached excerpt
from /var/log/messages).

Version-Release number of selected component (if applicable):
Kernel 2.6.24.3-34.fc8

How reproducible:
Always happens after connecting and disconnecting the device a few times

Steps to Reproduce:
1. Connect and disconnect the WM5 device a few times
2. Check /var/log/messages for bug trace
  
Actual results:
USB stops working, and the kernel throws a bug trace from rndis_host

Expected results:
The device should not be connected using RNDIS, and USB support should continue
to work

Additional info:
None that I can think of
Comment 1 James Gregory 2008-03-22 19:37:50 EDT
Created attachment 298856 [details]
Excerpt from "messages" showing rndis_host bug trace
Comment 2 James Gregory 2008-03-24 19:11:58 EDT
After doing a bit of searching, it appears this bug was fixed in kernel 2.6.20
(see attached reference) albeit for Nokia devices. However, it is still
occurring under Fedora. Is it possible this patch has been missed out?
Comment 3 Chuck Ebbert 2008-03-26 17:22:24 EDT
If you want to prevent drivers from loading, blacklist them by adding them to
/etc/modprobe.d/blacklist
Comment 4 James Gregory 2008-03-26 18:00:45 EDT
Thanks Chuck. After some modifications to modprobe.conf (since I didn't know
about the blacklist), I've managed to stop ipaq and rndis_host loading, which
has stopped the crashing. However, that is only a workaround - presumably other
users are experiencing this issue so it probably needs fixing in the kernel.
Comment 5 Chuck Ebbert 2008-04-18 18:22:43 EDT

*** This bug has been marked as a duplicate of 442253 ***

Note You need to log in before you can comment on or make changes to this bug.