Bug 438621 - Kernel hangs with timeout while trying to load SATA then continues past it and says: "booting has failed" (MSI k9a platinum motherboard, AMD Athlon 64_X2 CPU.)
Kernel hangs with timeout while trying to load SATA then continues past it an...
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-22 23:22 EDT by jzimm0007
Modified: 2013-01-27 15:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 01:14:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jzimm0007 2008-03-22 23:22:13 EDT
Description of problem:
Kernel hangs with timeout while trying to load SATA then continues past it and
says: "booting has failed" (MSI k9a platinum motherboard, AMD Athlon 64_X2 CPU.)

Version-Release number of selected component (if applicable):;

Steps to Reproduce:
1. Turn on computer with fedora x86_64 version installed update to kernel via yum.
2. Remove the quiet option from the kernel at boot
3. Tell grub to boot the kernel
Actual results:
Hello. I updated to the latest kernel with the package updater ( and
am getting the following on boot:

ata2: Sata link up 3.0 Gbps (SStatus 123 SControl 300)
ata 200: failed to identify (io error, err_mask=0x4)
ata2: failed to recover some devices retrying in 5 secs
later after kernel moves past error... "booting has failed"

My motherboard is an MSI k9a platinum. It has 4 sata connections. The bios is
set on native IDE mode which didn't work. If I change it to legacy IDE mode, it
works fine. AHCI mode doesn't work either. Windows usually keeps rebooting if I
change this setting (at least it has in the past). The computer posts fine if
you save changes and exit from the bios, but when you boot into fedora, restart
it then it won't post, it says "4th ide master error press F1 to resume", I hit
F1 and I see a blank screen with a blinking cursor (No grub menu). In other
words the computer won't post in legacy IDE, I need native IDE to work.
Could someone please tell me how to fix this if it is a bug?

Expected results:
Kernel to load sata in native ide

Additional info:
I typed all of this by hand so bare with me if I made a mistake.
I saw a similar bug that (I believe said err_mask0x104).
This also affected kernel
There appears to be an issue with my motherboard if I set it to legacy IDE then
bootup the os shutdown the os and reboot. --JZ
Comment 1 jzimm0007 2008-03-22 23:26:20 EDT
I am marking this bug urgent, because the system won't boot at all.
Comment 2 jzimm0007 2008-04-04 21:19:09 EDT
Every kernel after (The one I am using) has not been able to
boot on my computer (Including I certainly hope this does not mean
that fedora 9 will not boot at all on my computer when it comes out on the 29th.
I  have. <Hardisk info> Western Digital Caviar SE16 WD3200AAKS 320GB 7200 RPM
16MB Cache SATA 3.0Gb/s Hard Drive - OEM
Comment 3 jzimm0007 2008-04-06 00:17:22 EDT
I got the kernel to boot on my computer with pci=nomsi option enabled. With
pci=nomsi pci=nommconf enabled caused the system to boot okay, but while it was
loading something (I forget what it was, it hung) I reset it and that is when I
tried just the pci=nomsi option. I am glad it works now (Thanks to bug
#:249469)! I can't wait to see what fedora 9 is going to be like. I am not sure
what to assign this bug to (resolved or notabug?). It is still a bug even though
it has a workaround. btw, I have a compaq presario v2000 (fedora 8 i386) laptop
with no floppy drive in it. In order to make it install fedora 8, I had to use
the option floppy.allowed_drive_mask=0 clocksource=acpi_pm so that it would
continue past the /sbin/loader part. Even when I used the rescue cd to fix
another issue (the bug that talks about a blank screen with "grub": fix
reinstall grub) I had to use the floppy.allowed_drive_mask=0 clocksource=acpi_pm
option. I really think (if they haven't already should be fixed.
Comment 4 Bug Zapper 2008-11-26 05:14:58 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 5 Bug Zapper 2009-01-09 01:14:27 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.