Bug 438624 - Annoying and useless error messages: An internal system error has occurred
Annoying and useless error messages: An internal system error has occurred
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F9PKBlocker
  Show dependency treegraph
 
Reported: 2008-03-23 06:18 EDT by Asko Tontti
Modified: 2008-04-26 04:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 04:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asko Tontti 2008-03-23 06:18:31 EDT
Description of problem:

When packagekit (pk-update-icon) cannot connect to the all configured
repositories I get very frequent error bubble messages that don't really say
anything: An internal system error has occurred.


Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.9-4.fc9.i386


How reproducible:

Steps to Reproduce:
1. change one configured repository to use baseurl that timeouts
2. wait an hour
  
Actual results:

You get one useless error message per hour


Expected results:

Actual error message (repository foobar has network problems: connection timed
out ...)

One error message per day


Additional info:
Comment 1 Richard Hughes 2008-03-28 16:17:36 EDT
Should be fixed in 0.1.10.
Comment 2 Richard Hughes 2008-03-29 06:05:00 EDT
Please reopen if this is still a problem.
Comment 3 Asko Tontti 2008-03-31 05:56:47 EDT
Richard, thanks.

With gnome-packagekit-0.1.10-1.fc9.i386 I still have to problems:

1) Error message is now much better but it is abruptly cut on "or" word:

  "No network connection available: Problem with loading repository metadata,
this can be caused by network problems or"

2) I still get those bubble messages way too often. I think there should be
limiter on how often packagekit will show this message. Once a day could be good
starting point?
Comment 4 Asko Tontti 2008-03-31 06:00:21 EDT
3) Error message says "No network connection available" but I have working
network connection :)  The real problem is that one of the repositories don't
response (timeout). Maybe the message still needs some fine tuning :)
Comment 5 Robin Norwood 2008-04-16 14:30:53 EDT
This is fixed upstream now.

Note You need to log in before you can comment on or make changes to this bug.