Bug 43863 - apmsleep kills eth0 interface using PCMCIA card
apmsleep kills eth0 interface using PCMCIA card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-07 13:48 EDT by John Nelson
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 13:52:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Nelson 2001-06-07 13:48:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9)
Gecko/20010505

Description of problem:
I use apmsleep to suspend my laptop which is also connected to a
DHCP ethernet network via eth0.  I suspend, go out to lunch and restore the
desktop with the reset button and all is well EXCEPT...
the eth0 interface is missing!  Pump does not work.  Ifconfig refuses to
bring the interface back up.  It's just gone.  Its as if the PCMCIA
ethernet card was being shut off (yet I have a green link light on the
interface).

Running the ifcfg startup script is also useless.  I have to physically
reboot the machine just like Windows (YEEECCHCHHHHHH!!!!).
I suspect apmsleep powered down the PCMICA interface and never powered it
back up.



How reproducible:
Always

Steps to Reproduce:
1. Use apmsleep --suspend 2:00 with DHCP network
2. Go away for a half an hour
3. Bring laptop back with reset button.
4. Do ifconfig... eth0 is gone!
	

Actual Results:  eth0 missing.

Expected Results:  eth0 should still be there.

Additional info:

Am I not doing the right thing?  I can understand it if 
the IP address doesn't get renewed but the physical interface
seems to have dissappeared.

Maybe the network interface is powered down and not getting powered
back up again (PCMCIA).
Comment 1 Need Real Name 2001-06-11 17:50:14 EDT
Similar problem: On Dell Latitude L400, ethernet is built-in, 3c905-TX per 
lspci (not a card, works even after service pcmcia stop) redhat 7.1, kernel
module is 3c59x When the laptop goes to sleep e.g. by closing the lid when on
battery) then after waking up eth0 does not work any more. Per ifconfig eth0 the
interface is there just all connections to the outside fail with "connection
refused". Trying to get it back manually, ifup eth0 and service network reload
fail. If the interface is configured with dhcp, IP address does not get
assigned.The bug occurs with fixed ip address as well as dhcp.

Workaround: (thanks, Johnray Fuller <jrfuller@redhat.com>): before
putting the machine to sleep, do ifdown eth0, then when it wakes up, ifup eth0 
- seems when the interface is down going to sleep does not mess it up.

Reproducible: every time

Similar problem: Have Dell Truemobile wireless card in pcmcia slot, gets
recognized and configured correctly as eth1, per iwconfig finds ESSID and all,
except attempts to bring it up by ifup or similar fail for no apparent reason.

Comment 2 John Nelson 2001-06-12 13:52:03 EDT
I tried shutting down the interface before putting it in sleep
mode and then bringing it back up after the apmsleep period but
the interface stayed down.  No DHCP assigned numbers appeared in
ifconfig after this.  Feel free to comment if I've done something
wrong.

Here's what I did:

% ifconfig eth0 down
% apmsleep --suspend 2:00

// go to lunch

// reset button

% ifconfig eth0 up

// still no connectivity

% pump -i eth0

// pump hangs

// reboot machine
Comment 3 Bernhard Rosenkraenzer 2001-06-26 09:18:00 EDT
Please try the current version (3.0final-32) and make sure you've enabled all 
workarounds for broken BIOSes in /etc/sysconfig/apmd.
Works for me (Gericom 3xC, {D,H}ell Latitude C800)

Note You need to log in before you can comment on or make changes to this bug.