Bug 438643 - Lastest update broken Miro. Misc crashes and video is getting wonky
Lastest update broken Miro. Misc crashes and video is getting wonky
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-23 15:45 EDT by Robert Middleswarth
Modified: 2008-04-16 01:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 01:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Middleswarth 2008-03-23 15:45:58 EDT
Description of problem:
Video displays but gets out of sync quickly.  Miro crashes every few Mins


Version-Release number of selected component (if applicable):
Miro-1.1.2-1.fc8


How reproducible:
Every Audio and video I display.
Comment 1 Robert Middleswarth 2008-03-23 15:58:52 EDT
Worked fine until a few days ago.  Looks like that latest batch of updates broke
something.  Note I had this problem before the latest Miro release.  I was
hoping the latest Miro update would fix it but it didn't.
Comment 2 Alex Lancaster 2008-03-23 17:32:25 EDT
There was a xine update which possibly broke video support.  What version of
xine-lib do have installed?
Comment 3 Robert Middleswarth 2008-03-23 17:42:03 EDT
I have xine-lib-1.1.11-1.fc8 installed.
Comment 4 Alex Lancaster 2008-03-23 17:53:59 EDT
I haven't been able to reproduce on my F-8 box yet.  That doesn't mean it isn't
a problem, however.  Have you tried miro after a clean reboot and restart of X?
 Sometimes that has fixed various video issues related to X before.

If you could also try falling back to the previous xine-lib version and see if
you can reproduce the bug there, that would be very helpful.
Comment 5 Robert Middleswarth 2008-03-23 17:57:56 EDT
Rebooting is the 1st thing I would try before righting at ticket.  I will revert
1 version of xine-lib and see if that makes a diff.
Comment 6 Robert Middleswarth 2008-03-23 19:39:14 EDT
I revert back to xine-lib-1.1.8-4.fc8 and using Miro-1.1.2-1.fc8.  I ran miro
command line and this was my output.

[root@localhost Desktop]# miro
/usr/lib/firefox-2.0.0.12
INFO     Starting up Miro
INFO     Version:    1.1.2
INFO     Revision:  
https://svn.participatoryculture.org/svn/dtv/tags/Miro-1.1.2/tv/resources - 6194
INFO     Builder:    mockbuild@xenbuilder4.fedora.phx.redhat.com
INFO     Build Time: 1205247053.86
INFO     Loading preferences...
INFO     Showing startup dialog...
INFO     Starting event loop thread
INFO     Restoring database...
INFO     Connecting to /root/.miro/sqlitedb
TIMING   Database load slow: 0.077
INFO     Spawning global feed dtv:manualFeed
INFO     Spawning global feed dtv:singleFeed
INFO     Spawning global feed dtv:search
INFO     Spawning global feed dtv:searchDownloads
INFO     *** Launching Downloader Daemon ****
INFO     Creating channel tab order
INFO     Creating playlist tab order
INFO     Spawning Miro Guide...
INFO     Spawning global feed dtv:directoryfeed
INFO     Spawning auto downloader...
INFO     Displaying main frame...
WARNING  Menu item action "RenameVideo" not implemented
WARNING  Menu item action "FastForward" not implemented
WARNING  Menu item action "Rewind" not implemented
WARNING  Menu item action "UpVolume" not implemented
WARNING  Menu item action "DownVolume" not implemented
WARNING  Volume changed before videoDisplay created
INFO     Creating video display...
WARNING  Display updated before video display was created
INFO     loaded renderer 'xinerenderer'
TIMING   gtkAsyncMethod: <function initRenderers at 0x912ef7c> took too long: 2.288
TIMING   gtkSyncMethod: <function getDisplay at 0x91c5304> took too long: 2.352
INFO     First URL is https://www.miroguide.com/firsttime
TIMING   Icon clear: 0.001
INFO     Starting movie data updates
INFO     Finished startup sequence
TIMING   idle (finalizing startup) too slow (2.726 secs)
INFO     Adding default feeds
u'http://www.getmiro.com/screencasts/windows/win.feed.rss'
(u'Starter Channels', [u'http://richie-b.blip.tv/posts/?skin=rss',
u'http://feeds.pbs.org/pbs/kcet/wiredscience-video',
u'http://www.jpl.nasa.gov/multimedia/rss/podfeed-hd.xml',
u'http://www.linktv.org/rss/hq/mosaic.xml'])
INFO     got file:///tmp/tmpmS69PW.html
TIMING   gtkAsyncMethod: <function selectDisplay at 0x91c5294> took too long: 3.293
TIMING   idle (_installDefaultFeeds() (using asUrgent)) too slow (3.306 secs)
INFO     Checking for updates...
INFO     *** Daemon ready ***
INFO     Up to date.
INFO     got file:///tmp/tmp9quJfb.html
INFO     First URL is https://www.miroguide.com/
INFO     got file:///usr/share/miro/resources/html/guide-navigation.html
INFO     First URL is https://www.miroguide.com/
INFO     got https://www.miroguide.com/firsttime
INFO     First URL is https://www.miroguide.com/
WARNING  Error resizing /root/.miro/icon-cache/win.autodownload.34778294.jpg to
108x81:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/miro/imageresize.py", line 60, in
multiResizeImage
    resizeImage(source_filename, resizedPath, width, height)
  File "/usr/lib/python2.5/site-packages/miro/platformutils.py", line 235, in
resizeImage
    ignore_stderr=True)
  File "/usr/lib/python2.5/site-packages/miro/util.py", line 713, in call_command
    stdout, stderr = pipe.communicate()
  File "/usr/lib/python2.5/subprocess.py", line 667, in communicate
    return self._communicate(input)
  File "/usr/lib/python2.5/subprocess.py", line 1138, in _communicate
    rlist, wlist, xlist = select.select(read_set, write_set, [])
error: (4, 'Interrupted system call')

WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme:
WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme:
WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme:
INFO     got
action:handleSelect?area=tablist&viewName=feedTabs&id=24&shiftDown=0&ctrlDown=0
INFO     got file:///tmp/tmpERfT83.html
INFO     got action:startDownload?item=31
TIMING   timeout (Save database) too slow (0.625 secs)
INFO     moving to movies directory filename is /root/Movies/Miro/Incomplete
Downloads/Miropcf-TheBasicsOfMiro170.mp4.part
INFO     got action:playViewNamed?viewName=newItems&firstItemId=31
INFO     Playing item with renderer:
<frontend_implementation.xinerenderer.Renderer instance at 0x950268c>
INFO     got file:///tmp/tmplnTX67.html
/usr/bin/miro: line 3: 25645 Segmentation fault     
LD_LIBRARY_PATH=/usr/lib/firefox-2.0.0.12 ADDON_PATH=/tmp/empty miro.real "$@"
WARNING  downloader: connection closed -- quitting
INFO     Shutting down downloaders...
Comment 7 Robert Middleswarth 2008-03-23 19:59:57 EDT
OK this is fun.  I upgraded to latest Xine and it is working fine now.
Comment 8 Jack Deslippe 2008-04-16 01:58:47 EDT
This is probably related to the following Bug 441705 - The next xine-lib update
should fix this.  

Note You need to log in before you can comment on or make changes to this bug.